summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichele Mocciola2015-06-28 16:03:59 +0200
committerMichele Mocciola2015-06-28 16:03:59 +0200
commit96a6a56818393453ee38bb796579fbf5425765b8 (patch)
tree1bcc6711431e71b97ff0bb3e10e3e2ecf4a2b6ef
downloadaur-omniorbpy36.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD38
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..736f39696d25
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by makepkg 4.2.1
+# Tue Mar 10 22:10:20 UTC 2015
+pkgbase = omniorbpy36
+ pkgdesc = omniORB is a CORBA object request broker for C++ and Python. Legacy version.
+ pkgver = 3.6
+ pkgrel = 1
+ url = http://omniorb.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = omniorb416
+ depends = python2
+ provides = pyorbit
+ provides = omniorbpy=3.6
+ conflicts = omniorbpy-omg
+ conflicts = pyorbit
+ conflicts = omniorbpy
+ source = http://downloads.sourceforge.net/omniorb/omniORBpy-3.6.tar.bz2
+ md5sums = a7ab4789b913313f18a1171ff7a140b7
+
+pkgname = omniorbpy36
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c39be9b3b78c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: mickele
+# Contributor: Brice Méalier <mealier_brice *at* yahoo *dot* fr>
+# Contributor: Essien Ita Essien <me *at* essienitaessien *dot* com>
+# Contributor: Tobias Sandmann <tSa *at* gmx *dot* eu>
+# Contributor: pfm <nl081130 *at* yahoo *dot* de>
+# Contributor: mortbauer <mortbauer *at* gmail *dot* com>
+
+pkgname=omniorbpy36
+pkgver=3.6
+pkgrel=1
+pkgdesc="omniORB is a CORBA object request broker for C++ and Python. Legacy version."
+arch=(i686 x86_64)
+url="http://omniorb.sourceforge.net/"
+license=('LGPL')
+depends=('omniorb416' 'python2')
+conflicts=('omniorbpy-omg' 'pyorbit' 'omniorbpy')
+provides=('pyorbit' 'omniorbpy=3.6')
+source=(http://downloads.sourceforge.net/omniorb/omniORBpy-$pkgver.tar.bz2)
+
+build() {
+ mkdir -p -- "$srcdir/omniORBpy-$pkgver/build"
+ cd -- "$srcdir/omniORBpy-$pkgver/build"
+ ../configure PYTHON=/usr/bin/python2 --prefix=/usr
+ make
+}
+
+package() {
+ cd -- "$srcdir/omniORBpy-$pkgver/build"
+ make DESTDIR="$pkgdir" install
+
+ rm -rf "$pkgdir"/usr/lib/python2.7/site-packages/omniidl_be/__init__.py*
+
+ # adjust directory permissions
+ find "$pkgdir" -type d -exec chmod 755 '{}' \;
+ chmod 775 "$pkgdir"/{usr/include/omniORB4/,usr/lib/python2.7/site-packages/omniidl_be/}
+
+}
+md5sums=('a7ab4789b913313f18a1171ff7a140b7')