summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxwell Pray2022-05-18 12:51:39 -0700
committerMaxwell Pray2022-05-18 12:51:39 -0700
commit85573f621f5843e1a48895e57867bfea38465eb2 (patch)
tree60da144b85e65af995ef5b95b76bfad74e0a4539
downloadaur-85573f621f5843e1a48895e57867bfea38465eb2.tar.gz
Initial commit.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e0d34b6d830c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = omnisharp-vim-git
+ pkgdesc = Vim omnicompletion (intellisense) and more for C#.
+ pkgver = r1779.d322a70
+ pkgrel = 1
+ url = https://github.com/OmniSharp/omnisharp-vim
+ arch = any
+ license = MIT
+ depends = omnisharp-roslyn
+ source = git+https://github.com/OmniSharp/omnisharp-vim.git
+ md5sums = SKIP
+
+pkgname = omnisharp-vim-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..653466da9e6a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Maxwell Pray <synthead@gmail.com>
+
+_pkgname=omnisharp-vim
+pkgname=$_pkgname-git
+pkgver=r1779.d322a70
+pkgrel=1
+pkgdesc="Vim omnicompletion (intellisense) and more for C#."
+arch=("any")
+url="https://github.com/OmniSharp/$_pkgname"
+license=("MIT")
+source=("git+https://github.com/OmniSharp/$_pkgname.git")
+depends=("omnisharp-roslyn")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -dm 755 "$pkgdir/usr/share/vim/vimfiles"
+
+ for dir in ale_linters autoload doc ftdetect ftplugin plugin syntax syntax_checkers; do
+ cp -r "$srcdir/$_pkgname/$dir" "$pkgdir/usr/share/vim/vimfiles"
+ done
+}