summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroli2015-06-29 22:25:17 +0200
committeroli2015-06-29 22:25:17 +0200
commite33c1e0d81a65369a787e1df9296d4009582d0b7 (patch)
tree4aa7ba9fd27f9840922c681a75f83a16fbda55f1
downloadaur-e33c1e0d81a65369a787e1df9296d4009582d0b7.tar.gz
updated
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD40
-rw-r--r--omnitux.desktop9
-rw-r--r--omnitux.sh4
4 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52f768e9378e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = omnitux
+ pkgdesc = Educational game based on multimedia elements
+ pkgver = 1.2.1
+ pkgrel = 2
+ url = http://omnitux.sourceforge.net/
+ arch = any
+ license = GPL3
+ license = custom
+ depends = pygtk
+ depends = python2-pygame
+ source = http://downloads.sourceforge.net/omnitux/omnitux-1.2.1.tar.bz2
+ source = omnitux.desktop
+ source = omnitux.sh
+ md5sums = e0c4da272baaa4f09b90cc060f7b605c
+ md5sums = f3e3a6f39925f9449c467f78d030a69a
+ md5sums = cce915823d01fc9eb169cf9c1983db25
+
+pkgname = omnitux
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c86c72b496a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
+# Contributor: Dany Martineau <dany.luc.martineau@gmail.com>
+# Maintainer: Jose Riha <jose1711 gmail com>
+
+pkgname=omnitux
+pkgver=1.2.1
+pkgrel=2
+pkgdesc="Educational game based on multimedia elements"
+arch=('any')
+url="http://omnitux.sourceforge.net/"
+license=('GPL3' 'custom')
+depends=('pygtk' 'python2-pygame')
+source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.bz2"
+ "${pkgname}.desktop"
+ "${pkgname}.sh")
+md5sums=('e0c4da272baaa4f09b90cc060f7b605c'
+ 'f3e3a6f39925f9449c467f78d030a69a'
+ 'cce915823d01fc9eb169cf9c1983db25')
+
+package() {
+ cd "${srcdir}/${pkgname}"
+
+ # Fix a compatibility with Python 2
+ sed -i "s/python/python2/" "${pkgname}"{,_setup}.sh
+
+ # Install game files
+ mkdir -p "${pkgdir}/usr/share/${pkgname}"
+ cp -r bin data log *.sh "${pkgdir}/usr/share/${pkgname}"
+
+ # Install the launcher
+ install -Dm755 "../${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
+
+ # Install doc files
+ install -Dm644 README.txt "${pkgdir}/usr/share/doc/${pkgname}/README"
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # Install the pixmap and .desktop file
+ install -Dm644 data/default/icons/Omnitux_logo.svg "${pkgdir}/usr/share/pixmaps/${pkgname}.svg"
+ install -Dm644 "../${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+}
diff --git a/omnitux.desktop b/omnitux.desktop
new file mode 100644
index 000000000000..6a0eeb394180
--- /dev/null
+++ b/omnitux.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=Omnitux
+Comment=Educational game based on multimedia elements
+Comment[fr]=Un jeu d'éducation basé sur des éléments multimédias
+Exec=omnitux
+Icon=omnitux.svg
+Terminal=false
+Categories=Game;KidsGame
diff --git a/omnitux.sh b/omnitux.sh
new file mode 100644
index 000000000000..08b11d06c778
--- /dev/null
+++ b/omnitux.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd /usr/share/omnitux
+./omnitux.sh