summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDJ Griffin2019-02-11 02:28:37 -0500
committerDJ Griffin2019-02-11 02:28:37 -0500
commitc10be3e01ee51fe6b09a675c7083c36d4b3dd107 (patch)
treef2b984751ceeb8073b9c7f9bbc151f83cc82e0ad
parentcc5ade06a2d0bfd9ff6c01a0e3faebb0ad81c843 (diff)
downloadaur-c10be3e01ee51fe6b09a675c7083c36d4b3dd107.tar.gz
Metadata improvements and bugfixes.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad7f3b521ab2..4ea5974d183e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = omp
pkgdesc = Open-Source Music Player
pkgver = 0.1.1
- pkgrel = 2
+ pkgrel = 3
url = https://openmusicplayer.com/
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 7098b67e8d24..700bbc074ddf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=omp
pkgver=0.1.1
-pkgrel=2
+pkgrel=3
pkgdesc='Open-Source Music Player'
url='https://openmusicplayer.com/'
arch=(x86_64)
@@ -18,7 +18,13 @@ sha256sums=('SKIP')
build() {
cd "OMP-$pkgver"
- make -e FLATPAK=1
+
+ CXXFLAGS='-g -DFLATPAK=$(FLATPAK) -std=c++17 -Wall -pipe'
+ CXXFLAGS+=' -Wno-deprecated-declarations '
+ CXXFLAGS+=' -Wno-parentheses -fconcepts -Wno-catch-value -Wno-return-type'
+
+ make -e FLATPAK=0 CXXFLAGS=$(CXXFLAGS)
+
}
package() {