summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDJ Griffin2018-12-31 05:56:45 -0500
committerDJ Griffin2018-12-31 05:56:45 -0500
commitd2f4ed8a9728f4904f80b95ec148977e4a198922 (patch)
treef9278e82bf5656b292068410e276611cab1146b8
downloadaur-d2f4ed8a9728f4904f80b95ec148977e4a198922.tar.gz
First main OMP release AUR package.
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD32
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a33609a5ebdb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = omp
+ pkgdesc = Open-Source Music Player
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://openmusicplayer.com/
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = gstreamer
+ depends = gst-libav
+ depends = gst-plugins-bad
+ depends = gst-plugins-base
+ depends = gst-plugins-base-libs
+ depends = gst-plugins-good
+ depends = gst-plugins-ugly
+ depends = gtkmm3
+ depends = libclastfm
+ depends = libconfig
+ depends = sqlite
+ depends = taglib
+ provides = omp
+ conflicts = omp
+ conflicts = omp-git
+ source = omp-0.1.tar.gz::https://github.com/TheWiseNoob/OMP/archive/0.1.tar.gz
+ sha256sums = SKIP
+
+pkgname = omp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7400bb3ffe4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: DJ Griffin <thewisenoob@gmail.com>
+
+pkgname=omp
+pkgver=0.1
+pkgrel=1
+pkgdesc='Open-Source Music Player'
+url='https://openmusicplayer.com/'
+arch=(x86_64)
+license=(GPL3)
+depends=(gstreamer gst-libav gst-plugins-bad gst-plugins-base
+ gst-plugins-base-libs gst-plugins-good gst-plugins-ugly gtkmm3
+ libclastfm libconfig sqlite taglib)
+makedepends=(git)
+provides=('omp')
+conflicts=('omp' 'omp-git')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/TheWiseNoob/OMP/archive/$pkgver.tar.gz")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname}"
+ make
+}
+
+package() {
+ cd "${pkgname}"
+ make install DESTDIR=${pkgdir}
+}