summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWil Thomason2019-11-07 15:09:24 -0500
committerWil Thomason2019-11-07 15:09:24 -0500
commit02e38b16e6a20b60007c7b45b5fa961e2bb51f92 (patch)
tree1656baeafc3626bec824668698daf71cea428673
parente495257c1fc15def34ff5a30049fd56add9f6ada (diff)
downloadaur-02e38b16e6a20b60007c7b45b5fa961e2bb51f92.tar.gz
Use the Github repo where active development now lives
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94f0638a2b88..a58ecdeed9f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,8 +14,8 @@ pkgbase = ompl
optdepends = py++: Python binding
optdepends = ode: Plan using the Open Dynamics Engine
optdepends = eigen: For an informed sampling technique
- source = https://bitbucket.org/ompl/ompl/downloads/ompl-1.4.2-Source.tar.gz
- sha512sums = 1dc477ee471c0570fd94838b072105960e09186f29634e2f61d885153df36532ab40e30912b534c61f222c09dad63fc6097d324b53c265f9284f20c585d3095c
+ source = https://github.com/ompl/ompl/archive/1.4.2.tar.gz
+ sha512sums = 67cd99ee80b2c74a35eb54ce1ed4faf19fafc58843d9a9eaf29d28ef0707623517ccf9571af4af094455309950ea8f38d56f5c04d963f5e7a2410a7638e6e5fa
pkgname = ompl
diff --git a/PKGBUILD b/PKGBUILD
index 731771a075d4..b976f3427e1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,18 +13,18 @@ makedepends=('boost' 'cmake')
optdepends=('py++: Python binding'
'ode: Plan using the Open Dynamics Engine'
'eigen: For an informed sampling technique')
-source=(https://bitbucket.org/ompl/ompl/downloads/${pkgname}-${pkgver}-Source.tar.gz)
-sha512sums=('1dc477ee471c0570fd94838b072105960e09186f29634e2f61d885153df36532ab40e30912b534c61f222c09dad63fc6097d324b53c265f9284f20c585d3095c')
+source=(https://github.com/ompl/ompl/archive/${pkgver}.tar.gz)
+sha512sums=(67cd99ee80b2c74a35eb54ce1ed4faf19fafc58843d9a9eaf29d28ef0707623517ccf9571af4af094455309950ea8f38d56f5c04d963f5e7a2410a7638e6e5fa)
prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}-Source"
+ cd "${srcdir}/${pkgname}-${pkgver}"
rm -rf build
mkdir build
}
build() {
- cd "${srcdir}/${pkgname}-${pkgver}-Source/build"
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
cmake -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
@@ -36,13 +36,13 @@ build() {
}
check() {
- cd "${srcdir}/${pkgname}-${pkgver}-Source/build"
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
#make test
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}-Source"
+ cd "${srcdir}/${pkgname}-${pkgver}"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"