summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven Schneider2012-08-20 15:59:16 +0200
committerSven Schneider2012-08-20 15:59:16 +0200
commit25cad29760cd89e8b8c4c3e176f9568b1189ff27 (patch)
treeaa41d13eba2099c5b4a00ed820d9682bbbf68eb6
downloadaur-25cad29760cd89e8b8c4c3e176f9568b1189ff27.tar.gz
ompl: added
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..82cdd4a908ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ompl
+ pkgdesc = The Open Motion Planning Library (OMPL) consists of many state-of-the-art sampling-based motion planning algorithms
+ pkgver = 0.11.1
+ pkgrel = 1
+ url = http://ompl.kavrakilab.org/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = cmake
+ depends = boost
+ optdepends = py++: Python binding
+ optdepends = ode: Plan using the Open Dynamics Engine
+ source = https://bitbucket.org/ompl/ompl/downloads/ompl-0.11.1-Source.tar.gz
+ md5sums = 235ca56932ff20da0c01f8201657740a
+
+pkgname = ompl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64747316b84f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Sven Schneider <archlinux.sandmann@googlemail.com>
+
+pkgname=ompl
+pkgver=0.11.1
+pkgrel=1
+pkgdesc="The Open Motion Planning Library (OMPL) consists of many state-of-the-art sampling-based motion planning algorithms"
+arch=('i686' 'x86_64')
+url="http://ompl.kavrakilab.org/"
+license=('BSD')
+depends=('boost')
+makedepends=('cmake')
+optdepends=('py++: Python binding'
+ 'ode: Plan using the Open Dynamics Engine')
+source=(https://bitbucket.org/ompl/ompl/downloads/${pkgname}-${pkgver}-Source.tar.gz)
+md5sums=('235ca56932ff20da0c01f8201657740a')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}-Source"
+
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DPYTHON_EXEC=/usr/bin/python2 -DCMAKE_CXX_FLAGS=-D_POSIX_VERSION .
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}-Source"
+
+ make DESTDIR=${pkgdir} install
+}
+