summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Delafosse2021-11-15 21:20:35 +0100
committerPaul Delafosse2021-11-15 21:20:35 +0100
commitc9f4cbaedc88052307e68941848cd4ba548a711b (patch)
treeff93d7fca3b39c1c4e7bfa633b117d09b42a41c2
parentc1e6cb8b4edb2fc92e36947aa5716f561f12e355 (diff)
downloadaur-c9f4cbaedc88052307e68941848cd4ba548a711b.tar.gz
fix: add package depedencies
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 4 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9267c8351c9a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+onagre-git**
+PKGBUILD-namcap.log
+onagre/
diff --git a/PKGBUILD b/PKGBUILD
index f73910bd8725..2e081fa98731 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
pkgname=onagre-git
-pkgver=0.1.0.r79.g217e815
+pkgver=0.1.0.r116.g6168926
pkgrel=1
pkgdesc='A general purpose application launcher for X and wayland inspired by rofi/wofi and alfred'
arch=('x86_64')
url='https://github.com/oknozor/onagre'
license=('MIT')
-makedepends=('git' 'rust')
+makedepends=('git' 'rust' 'fontconfig' 'cmake' 'freetype2' 'libxkbcommon')
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
#install="${pkgname%-*}.install"
@@ -17,12 +17,17 @@ pkgver() {
echo $(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2).r$(git rev-list --count HEAD).g$(git describe --always)
}
+prepare() {
+ cd "${pkgname%-git}"
+ cargo fetch --locked
+}
+
build() {
cd "${pkgname%-*}"
- cargo build --release
+ cargo build --release --frozen
}
package() {
cd "${pkgname%-*}"
- install -Dm755 target/release/onagre "$pkgdir/usr/bin/onagre"
+ install -Dm 755 target/release/onagre "$pkgdir/usr/bin/onagre"
}