summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAkhil Jalagam2019-08-30 19:36:45 +0530
committerAkhil Jalagam2019-08-30 19:36:45 +0530
commit7f472614b42383627d6631b449e768ca44ac8656 (patch)
tree5025dd8572e332307d792f005100957d069202e9
downloadaur-7f472614b42383627d6631b449e768ca44ac8656.tar.gz
ondir-git - new package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..313eca20ab68
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ondir-git
+ pkgdesc = a small program to automate tasks specific to certain directories
+ pkgver = r13.55279f0
+ pkgrel = 1
+ url = https://github.com/alecthomas/ondir
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = glibc
+ provides = ondir
+ conflicts = ondir
+ source = git://github.com/alecthomas/ondir.git
+ md5sums = SKIP
+
+pkgname = ondir-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a57f33f3834
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Akhil Jalagam <akhiljalagams@gmail.com>
+
+_pkgname=ondir
+pkgname=$_pkgname-git
+pkgver=r13.55279f0
+pkgrel=1
+pkgdesc="a small program to automate tasks specific to certain directories"
+arch=('i686' 'x86_64')
+url="https://github.com/alecthomas/ondir"
+license=('GPL2')
+makedepends=('git')
+depends=('glibc')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git://github.com/alecthomas/ondir.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ make CFLAGS="$CFLAGS "'-DVERSION=\"$(VERSION)\" -DGLOBAL_CONF=\"$(CONF)\"' LDFLAGS="$LDFLAGS"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make DESTDIR="$pkgdir/" install
+}