summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorakhil2021-05-24 19:08:52 +0530
committerakhil2021-05-24 19:08:52 +0530
commite40f01101f60a7763f2283f68d8dbf54537988c3 (patch)
tree6c8ff4618f10cf1d1fed271274174683186a2376
parent6fd1e26ca535f9dcc99181e57f6271b8949d6017 (diff)
downloadaur-e40f01101f60a7763f2283f68d8dbf54537988c3.tar.gz
minor fixes
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD23
2 files changed, 16 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d3b0fac7960..b7c76a601d29 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = ondir-git
pkgdesc = a small program to automate tasks specific to certain directories
- pkgver = r14.017b4c6
+ pkgver = r13.55279f0
pkgrel = 1
- url = https://github.com/4khi1/ondir
+ url = https://github.com/alecthomas/ondir.git
arch = i686
arch = x86_64
license = GPL2
makedepends = git
depends = glibc
- provides = ondir
- conflicts = ondir
- source = git://github.com/4khi1/ondir.git
+ provides = ondir-git
+ conflicts = ondir-git
+ source = ondir-git::git://github.com/alecthomas/ondir.git
md5sums = SKIP
pkgname = ondir-git
diff --git a/PKGBUILD b/PKGBUILD
index 8b5f4cba26e7..ccfb50a9ded0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,30 @@
-# Maintainer: Akhil Jalagam <akhiljalagams@gmail.com>
+# Maintainer: Akhil J <akhil.j@outlook.in>
-_pkgname=ondir
-pkgname=$_pkgname-git
-pkgver=r14.017b4c6
+pkgname=ondir-git
+pkgver=r13.55279f0
pkgrel=1
pkgdesc="a small program to automate tasks specific to certain directories"
arch=('i686' 'x86_64')
-url="https://github.com/4khi1/ondir"
+url="https://github.com/alecthomas/ondir.git"
license=('GPL2')
makedepends=('git')
depends=('glibc')
-provides=("$_pkgname")
-conflicts=("$_pkgname")
-source=("git://github.com/4khi1/ondir.git")
+provides=("$pkgname")
+conflicts=("$pkgname")
+source=("$pkgname::git://github.com/alecthomas/ondir.git")
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/$_pkgname"
+ cd "$pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$srcdir/$_pkgname"
+ cd "$pkgname"
make CFLAGS="$CFLAGS "'-DVERSION=\"$(VERSION)\" -DGLOBAL_CONF=\"$(CONF)\"' LDFLAGS="$LDFLAGS"
}
package() {
- cd "$srcdir/$_pkgname"
- make DESTDIR="$pkgdir/" install
+ cd "$pkgname"
+ make DESTDIR="$pkgdir" install
}