summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornwg-piotr2017-12-29 03:09:51 +0100
committernwg-piotr2017-12-29 03:09:51 +0100
commitb3d51c5581aa5023fb53bd2aa64c1ae8bbef600d (patch)
treedcfe2d737d261593aa1b8bfbca0027c8096862ce
downloadaur-b3d51c5581aa5023fb53bd2aa64c1ae8bbef600d.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD33
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c9d76347e3e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = one-more-cheese
+ pkgdesc = Arcade-puzzle game
+ pkgver = 0.1.0
+ pkgrel = 3
+ url = http://nwg.pl/cheese
+ arch = i686
+ arch = x86_64
+ license = freeware
+ depends = python3
+ depends = python-pygame
+ depends = python-requests
+ source = http://nwg.pl/mice/download/one-more-cheese-0.1.0.tar.gz
+ source = http://nwg.pl/mice/download/one-more-cheese
+ source = http://nwg.pl/mice/download/one-more-cheese.desktop
+ source = http://nwg.pl/mice/download/one-more-cheese.png
+ md5sums = b7738c24db1da0516fc694a67ec3fd37
+ md5sums = af54e54383a7bdb5fa13ffa1c023f831
+ md5sums = 8c44865338673c7a9ff646d23af1b172
+ md5sums = 15b45413c215260baf7c462cbbdde183
+
+pkgname = one-more-cheese
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dba9b8420247
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Piotr Miller <nwg.piotr@gmail.com>
+pkgname=('one-more-cheese')
+pkgver=0.1.0
+pkgrel=3
+pkgdesc="Arcade-puzzle game"
+arch=('i686' 'x86_64')
+url="http://nwg.pl/cheese"
+license=('freeware')
+depends=('python3' 'python-pygame' python-requests)
+source=("http://nwg.pl/mice/download/one-more-cheese-0.1.0.tar.gz"
+"http://nwg.pl/mice/download/one-more-cheese"
+"http://nwg.pl/mice/download/one-more-cheese.desktop"
+"http://nwg.pl/mice/download/one-more-cheese.png")
+
+md5sums=('b7738c24db1da0516fc694a67ec3fd37'
+ 'af54e54383a7bdb5fa13ffa1c023f831'
+ '8c44865338673c7a9ff646d23af1b172'
+ '15b45413c215260baf7c462cbbdde183')
+
+package() {
+ install -D -m 755 one-more-cheese \
+ "$pkgdir"/usr/bin/one-more-cheese
+ install -D -m 755 one-more-cheese.desktop \
+ "$pkgdir"/usr/share/applications/one-more-cheese.desktop
+ install -D -m 644 one-more-cheese.png \
+ "$pkgdir"/usr/share/one-more-cheese/one-more-cheese.png
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et:
+
+