summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorD. Can Celasun2016-11-06 19:28:12 +0100
committerD. Can Celasun2016-11-06 19:28:12 +0100
commit59e2508ed39748c8b56fa2ea33b17e198cefb792 (patch)
tree837b45d5010829f2af845c0f6d604e7971a23272
downloadaur-59e2508ed39748c8b56fa2ea33b17e198cefb792.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD48
-rwxr-xr-xone-night-stand2
-rw-r--r--one-night-stand.desktop9
-rw-r--r--one-night-stand.pngbin0 -> 95530 bytes
5 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ac77739e8a00
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Sun Nov 6 18:28:07 UTC 2016
+pkgbase = one-night-stand
+ pkgdesc = A game about the morning after a one night stand.
+ pkgver = 2.04
+ pkgrel = 1
+ url = https://kinmoku.itch.io/one-night-stand
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = lib32-libgl
+ depends = lib32-gdk-pixbuf2
+ depends = lib32-libxcursor
+ depends = lib32-libxrandr
+ options = !strip
+ source = one-night-stand
+ source = one-night-stand.desktop
+ source = one-night-stand.png
+ md5sums = 2657cf2dc573bd4a64f72206006df0e5
+ md5sums = bcbceaa2d0ec7d28b463fa7bcefe1ec0
+ md5sums = c4940f2ee254374eb096bc46b82bdae7
+
+pkgname = one-night-stand
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..20963ef91536
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Can Celasun <dcelasun[at]gmail[dot]com>
+pkgname=one-night-stand
+_pkgname=One_Night_Stand
+pkgver=2.04
+pkgrel=1
+pkgdesc="A game about the morning after a one night stand."
+arch=(i686 x86_64)
+url="https://kinmoku.itch.io/one-night-stand"
+license=('custom')
+depends=(lib32-libgl lib32-gdk-pixbuf2 lib32-libxcursor lib32-libxrandr)
+options=(!strip)
+source=($pkgname
+ $pkgname.desktop
+ $pkgname.png)
+md5sums=('2657cf2dc573bd4a64f72206006df0e5'
+ 'bcbceaa2d0ec7d28b463fa7bcefe1ec0'
+ 'c4940f2ee254374eb096bc46b82bdae7')
+_pkg=${_pkgname}_$pkgver-linux.tar.bz2
+package() {
+ msg "You need a full copy of the game in order to install it"
+ msg "You can download it here: https://kinmoku.itch.io/one-night-stand"
+ msg "Searching for ${_pkg} in dir: \"$startdir\""
+ pkgpath="$startdir"
+ if [[ ! -f "${pkgpath}/${_pkg}" ]]; then
+ error "Game package not found, please type absolute path to ${_pkg} (/home/joe):"
+ read pkgpath
+ if [[ ! -f "${pkgpath}/${_pkg}" ]]; then
+ error "Unable to find game package." && return 1
+ fi
+ fi
+ msg "Found package, unpacking..."
+ tar xf "${pkgpath}/${_pkg}" -C "${srcdir}"
+
+ mkdir -p "${pkgdir}"/usr/bin
+ mkdir -p "${pkgdir}"/opt/${pkgname}
+ mkdir -p "${pkgdir}"/usr/share/{applications,icons}
+
+ cd "${srcdir}"/${_pkgname}_${pkgver}-linux
+
+ cp * "${pkgdir}"/opt/${pkgname} -R
+
+ install -m755 "${srcdir}"/$pkgname "${pkgdir}"/usr/bin/${pkgname}
+
+ install -m644 "${srcdir}"/${pkgname}.png "${pkgdir}"/usr/share/icons
+ install -m644 "${srcdir}"/${pkgname}.desktop "${pkgdir}"/usr/share/applications
+
+ chmod +x "${pkgdir}"/usr/bin/${pkgname}
+}
diff --git a/one-night-stand b/one-night-stand
new file mode 100755
index 000000000000..6ee063c8e014
--- /dev/null
+++ b/one-night-stand
@@ -0,0 +1,2 @@
+#!/bin/sh
+cd /opt/one-night-stand && sh One\ Night\ Stand.sh
diff --git a/one-night-stand.desktop b/one-night-stand.desktop
new file mode 100644
index 000000000000..1027fc8164a5
--- /dev/null
+++ b/one-night-stand.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Categories=Game;
+Exec=/usr/bin/one-night-stand
+Icon=one-night-stand
+Terminal=false
+Type=Application
+Name=One Night Stand
+Comment=A game about the morning after a one night stand.
+Name[en_US]=One Night Stand
diff --git a/one-night-stand.png b/one-night-stand.png
new file mode 100644
index 000000000000..bef79cca3442
--- /dev/null
+++ b/one-night-stand.png
Binary files differ