summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryjun1232020-09-08 21:57:02 +0800
committeryjun1232020-09-08 21:57:02 +0800
commit775fa8783e566d06950e915a205d3cad6b3a06fb (patch)
treeef3d5c411a5f49982a6a31747de08ec349fd75fc
downloadaur-775fa8783e566d06950e915a205d3cad6b3a06fb.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD42
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2c40697b1dfa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = one-tomato
+ pkgdesc = 一个使用dtk实现的番茄钟
+ pkgver = 1.0.4
+ pkgrel = 1
+ url = https://github.com/uiYzzi/one-tomato
+ arch = x86_64
+ license = GPL3
+ makedepends = qconf
+ depends = dtkwidget
+ source = one-tomato-1.0.4.tar.gz::https://github.com/uiYzzi/one-tomato/archive/1.0.4.tar.gz
+ source = one-tomato.desktop::https://raw.githubusercontent.com/uiYzzi/one-tomato/master/dabao/extract/opt/apps/top.yzzi.tomato/entries/applications/top.yzzi.tomato.desktop
+ source = one-tomato.svg::https://raw.githubusercontent.com/uiYzzi/one-tomato/master/dabao/extract/opt/apps/top.yzzi.tomato/entries/icons/top.yzzi.tomato.svg
+ sha256sums = 70a53d5e9f85a66863318f70455465b7c32c756ee76d93597fc4e49e5064dcb0
+ sha256sums = 624687f1759b5120ef6b18d56d7c05c03683d100fb36ccaa4198434d99248305
+ sha256sums = 1e8d671a4543852d2f7a7349dda1f27079a593d61a0c34598cab342bc6890ec1
+
+pkgname = one-tomato
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a6663b08147
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: yjun <jerrysteve1101@gmail.com>
+
+pkgname=one-tomato
+pkgver=1.0.4
+pkgrel=1
+pkgdesc="一个使用dtk实现的番茄钟"
+arch=('x86_64')
+url="https://github.com/uiYzzi/one-tomato"
+license=('GPL3')
+depends=('dtkwidget')
+makedepends=('qconf')
+source=(${pkgname}-${pkgver}.tar.gz::"https://github.com/uiYzzi/${pkgname}/archive/${pkgver}.tar.gz"
+ "${pkgname}.desktop::https://raw.githubusercontent.com/uiYzzi/one-tomato/master/dabao/extract/opt/apps/top.yzzi.tomato/entries/applications/top.yzzi.tomato.desktop"
+ "${pkgname}.svg::https://raw.githubusercontent.com/uiYzzi/one-tomato/master/dabao/extract/opt/apps/top.yzzi.tomato/entries/icons/top.yzzi.tomato.svg")
+sha256sums=('70a53d5e9f85a66863318f70455465b7c32c756ee76d93597fc4e49e5064dcb0'
+ '624687f1759b5120ef6b18d56d7c05c03683d100fb36ccaa4198434d99248305'
+ '1e8d671a4543852d2f7a7349dda1f27079a593d61a0c34598cab342bc6890ec1')
+
+build() {
+ cd ${pkgname}-${pkgver}
+
+ mkdir -p build
+ qmake ./${pkgname}.pro -spec linux-g++ CONFIG+=qtquickcompiler -o build/
+ make -C ./build
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+
+ # binary
+ install -Dm755 build/${pkgname} ${pkgdir}/usr/bin/${pkgname}
+
+ # desktop enrty
+ install -Dm644 ${srcdir}/${pkgname}.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
+ sed -i "s|/opt/apps/top.yzzi.tomato/files/one-tomato|${pkgname}|g" ${pkgdir}/usr/share/applications/${pkgname}.desktop
+ sed -i "s|top.yzzi.tomato|${pkgname}|g" ${pkgdir}/usr/share/applications/${pkgname}.desktop
+
+ # icon
+ install -Dm644 ${srcdir}/${pkgname}.svg ${pkgdir}/usr/share/pixmaps/${pkgname}.svg
+}
+
+# vim: set sw=2 ts=2 et: