summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2016-04-18 10:46:28 -0500
committerDoug Newgard2016-04-18 10:46:28 -0500
commit826c1d1440d85e1adaf32451d818c164a37537f7 (patch)
tree42d625bc6fc6bfe1ab36b8e64d5cf658f7b6c4bb
parenta8bfcec054eab22c60ab84d2fe5b95778c3ef78e (diff)
downloadaur-826c1d1440d85e1adaf32451d818c164a37537f7.tar.gz
Cleanup and move to user service
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
-rw-r--r--onedrive.install5
-rw-r--r--service.patch12
5 files changed, 25 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca85e75b397a..243304a214db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,17 @@
-# Generated by mksrcinfo v8
-# Mon Apr 18 14:23:11 UTC 2016
pkgbase = onedrive
pkgdesc = Free OneDrive client written in D
pkgver = 1.1
pkgrel = 1
url = https://github.com/skilion/onedrive
+ install = onedrive.install
arch = i686
arch = x86_64
license = GPL3
makedepends = dmd
depends = curl
depends = sqlite
- conflicts = onedrive-git
source = https://github.com/skilion/onedrive/archive/v1.1.tar.gz
- source = service.patch
sha256sums = c54fad2b452a6a84e009f8743efecdaaca37abcbfe046fc830d7e101cac3594d
- sha256sums = f53855c60d23a73119eba2b915b2504f1249a8ab0af179a0ef67a18b5cc46ad9
pkgname = onedrive
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..71a9d16c2b38
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*~
+*/
+*.tar.*
+*.log
diff --git a/PKGBUILD b/PKGBUILD
index d72d3cf6d07f..279d7da7e96d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,36 @@
-# Maintainer: Jameson Pugh <imntreal@gmail.com>
+# Contributor: Doug Newgard <scimmia at archlinux dot info>
+# Contributor: Jameson Pugh <imntreal@gmail.com>
pkgname=onedrive
pkgver=1.1
pkgrel=1
-pkgdesc="Free OneDrive client written in D"
+pkgdesc='Free OneDrive client written in D'
arch=('i686' 'x86_64')
-url="https://github.com/skilion/onedrive"
+url='https://github.com/skilion/onedrive'
license=('GPL3')
depends=('curl' 'sqlite')
makedepends=('dmd')
-conflicts=('onedrive-git')
-source=("https://github.com/skilion/onedrive/archive/v${pkgver}.tar.gz"
- 'service.patch')
-sha256sums=('c54fad2b452a6a84e009f8743efecdaaca37abcbfe046fc830d7e101cac3594d'
- 'f53855c60d23a73119eba2b915b2504f1249a8ab0af179a0ef67a18b5cc46ad9')
+install=$pkgname.install
+source=("https://github.com/skilion/onedrive/archive/v$pkgver.tar.gz")
+sha256sums=('c54fad2b452a6a84e009f8743efecdaaca37abcbfe046fc830d7e101cac3594d')
prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd $pkgname-$pkgver
- patch -p0 < ../service.patch
+ sed -i 's|/usr/local|/usr|g' onedrive.service
}
+
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd $pkgname-$pkgver
make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd $pkgname-$pkgver
- install -dm 755 "${pkgdir}/usr/bin"
- install -dm 755 "${pkgdir}/etc"
- install -dm 755 "${pkgdir}/usr/lib/systemd/system"
- install -m 755 onedrive "${pkgdir}/usr/bin/"
- install -m 644 onedrive.conf "${pkgdir}/etc/"
- install -m 644 onedrive.service "${pkgdir}/usr/lib/systemd/system/"
+ install -Dm755 onedrive "$pkgdir/usr/bin/onedrive"
+ install -Dm644 onedrive.conf "$pkgdir/etc/onedrive.conf"
+ install -Dm644 onedrive.service "$pkgdir/usr/lib/systemd/user/onedrive.service"
}
-# vim:set ts=2 sw=2 et:
diff --git a/onedrive.install b/onedrive.install
new file mode 100644
index 000000000000..5ce43b35620e
--- /dev/null
+++ b/onedrive.install
@@ -0,0 +1,5 @@
+post_install() {
+ printf "You will need to manually create ~/OneDrive after installation\n"
+ printf "or modify onedrive.conf to use a different directory"
+}
+
diff --git a/service.patch b/service.patch
deleted file mode 100644
index e7120f1f1b07..000000000000
--- a/service.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur onedrive.service-orig onedrive.service
---- onedrive.service-orig 2016-04-18 10:18:51.258761559 -0400
-+++ onedrive.service 2016-04-18 10:19:01.968883855 -0400
-@@ -3,7 +3,7 @@
- Documentation=https://github.com/skilion/onedrive
-
- [Service]
--ExecStart=/usr/local/bin/onedrive -m
-+ExecStart=/usr/bin/onedrive -m
- Restart=no
-
- [Install]