summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhullyb2023-01-23 16:54:49 +0800
committerzhullyb2023-01-23 16:54:49 +0800
commitd4c661eeafcd03af5096347acaf1c500d755d440 (patch)
tree5de5aac23b4eb578f6026e0705579ac9bb1942c9
downloadaur-d4c661eeafcd03af5096347acaf1c500d755d440.tar.gz
First commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD28
-rw-r--r--onedrivegui.desktop8
4 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..23bf3821a459
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = onedrivegui
+ pkgdesc = A simple GUI for OneDrive Linux client, with multi-account support.
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/bpozdena/OneDriveGUI
+ arch = any
+ license = GPL
+ depends = pyside6
+ depends = python-requests
+ depends = onedrive-abraunegg
+ depends = qt6-webengine
+ provides = onedrivegui
+ conflicts = onedrivegui-git
+ source = https://github.com/bpozdena/OneDriveGUI/archive/refs/tags/v1.0.1.tar.gz
+ source = onedrivegui.desktop
+ sha256sums = a92d16e288ac9aaeab1e00dad82d6c42feef5e25bbd8039ca5385d12f7874757
+ sha256sums = c531f57c3c8424f265c0aad2e93260eab071d066d75de2f7eebb47e41c644267
+
+pkgname = onedrivegui
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..681bcac2127f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.gz
+src
+pkg
+*.pkg.tar.*
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4545cf7ce02
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: zhullyb <zhullyb [at] outlook dot com>
+
+pkgname=onedrivegui
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="A simple GUI for OneDrive Linux client, with multi-account support."
+license=("GPL")
+depends=("pyside6" "python-requests" "onedrive-abraunegg" "qt6-webengine")
+makedepends=()
+conflicts=("onedrivegui-git")
+provides=("onedrivegui")
+arch=("any")
+url="https://github.com/bpozdena/OneDriveGUI"
+source=("https://github.com/bpozdena/OneDriveGUI/archive/refs/tags/v${pkgver}.tar.gz"
+ "onedrivegui.desktop")
+sha256sums=('a92d16e288ac9aaeab1e00dad82d6c42feef5e25bbd8039ca5385d12f7874757'
+ 'c531f57c3c8424f265c0aad2e93260eab071d066d75de2f7eebb47e41c644267')
+
+package(){
+ cd "${srcdir}/OneDriveGUI-${pkgver}"
+ mkdir -p "${pkgdir}/usr/lib/OneDriveGUI"
+ mkdir -p "${pkgdir}/usr/bin"
+ cp -r src/{resources,ui} "${pkgdir}/usr/lib/OneDriveGUI"
+ install -Dm644 src/resources/images/OneDriveGUI.png "${pkgdir}/usr/share/icons/hicolor/48x48/apps/OneDriveGUI.png"
+ install -Dm644 "${srcdir}/onedrivegui.desktop" "${pkgdir}/usr/share/applications/onedrivegui.desktop"
+ install -Dm755 src/OneDriveGUI.py "${pkgdir}/usr/lib/OneDriveGUI/OneDriveGUI.py"
+ ln -sf /usr/lib/OneDriveGUI/OneDriveGUI.py "${pkgdir}/usr/bin/onedrivegui"
+}
diff --git a/onedrivegui.desktop b/onedrivegui.desktop
new file mode 100644
index 000000000000..ebc8d296504a
--- /dev/null
+++ b/onedrivegui.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+StartupNotify=true
+Name=OneDriveGUI
+Comment=A simple GUI for OneDrive Linux client
+Exec=onedrivegui
+Icon=OneDriveGUI.png
+Categories=Network;Office \ No newline at end of file