summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2020-10-27 21:09:17 +0300
committerorhun2020-10-27 21:09:17 +0300
commit4e50a6c6469d233f5431bf2bbec8a1b29dd2594e (patch)
tree9187f67e9ca753bd722293a7bc9a4fb2f0491b3b
downloadaur-4e50a6c6469d233f5431bf2bbec8a1b29dd2594e.tar.gz
Initial upload: onefetch-bin 2.5.0-1
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD28
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5f5944f18449
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = onefetch-bin
+ pkgdesc = Git repository summary on your terminal
+ pkgver = 2.5.0
+ pkgrel = 1
+ url = https://github.com/o2sh/onefetch
+ arch = x86_64
+ license = MIT
+ depends = libgit2
+ provides = onefetch
+ conflicts = onefetch
+ conflicts = onefetch-git
+ source_x86_64 = https://github.com/o2sh/onefetch/releases/download/v2.5.0/onefetch-linux.tar.gz
+ source_x86_64 = onefetch-2.5.0-LICENSE.md::https://github.com/o2sh/onefetch/raw/v2.5.0/LICENSE.md
+ source_x86_64 = onefetch-2.5.0-README.md::https://github.com/o2sh/onefetch/raw/v2.5.0/README.md
+ source_x86_64 = onefetch-2.5.0-man.1::https://github.com/o2sh/onefetch/raw/master/onefetch.1
+ sha512sums_x86_64 = 6f150383324fb40c1168ef2458837ad19bdad13e29e3658e2b05e7fbc55a800080ff2c2e05110ef38c4b633239f6bc78173731603d59038ff3d6a863f4cf13ea
+ sha512sums_x86_64 = 57e2b42cf721a6a4e6643ad5084cf5149e2639a9e91ac643e0f55adf77f0af36204ca74857fb0debbb22b34123c86e2ec8020aa41c19d8d7b7463a9f85a0e87d
+ sha512sums_x86_64 = f72f8b11f9ebee0c4e5716692bc731069c63ff72672d5ba37e94fd58bc236776c99f795b6d0ec92b823c86ef7ab41250e5d12d48f8c9a6b5b26dab360d13c09a
+ sha512sums_x86_64 = f7ff9e4fa9a7774097ce818baaf39f2b8291582be7e15e0d56bc87fd74d600c8ce8c12efcf940f1741c9d85296c7fda30229dace45cdee9e0d5214215c09d33c
+
+pkgname = onefetch-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c85277f87b1d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# https://github.com/orhun/pkgbuilds
+
+pkgname=onefetch-bin
+pkgver=2.5.0
+pkgrel=1
+pkgdesc="Git repository summary on your terminal"
+arch=('x86_64')
+url="https://github.com/o2sh/onefetch"
+license=('MIT')
+conflicts=("${pkgname%-bin}" "${pkgname%-bin}-git")
+provides=("${pkgname%-bin}")
+depends=('libgit2')
+source_x86_64=("$url/releases/download/v$pkgver/${pkgname%-bin}-linux.tar.gz"
+ "${pkgname%-bin}-$pkgver-LICENSE.md::$url/raw/v$pkgver/LICENSE.md"
+ "${pkgname%-bin}-$pkgver-README.md::$url/raw/v$pkgver/README.md"
+ "${pkgname%-bin}-$pkgver-man.1::$url/raw/master/${pkgname%-bin}.1")
+sha512sums_x86_64=('6f150383324fb40c1168ef2458837ad19bdad13e29e3658e2b05e7fbc55a800080ff2c2e05110ef38c4b633239f6bc78173731603d59038ff3d6a863f4cf13ea'
+ '57e2b42cf721a6a4e6643ad5084cf5149e2639a9e91ac643e0f55adf77f0af36204ca74857fb0debbb22b34123c86e2ec8020aa41c19d8d7b7463a9f85a0e87d'
+ 'f72f8b11f9ebee0c4e5716692bc731069c63ff72672d5ba37e94fd58bc236776c99f795b6d0ec92b823c86ef7ab41250e5d12d48f8c9a6b5b26dab360d13c09a'
+ 'f7ff9e4fa9a7774097ce818baaf39f2b8291582be7e15e0d56bc87fd74d600c8ce8c12efcf940f1741c9d85296c7fda30229dace45cdee9e0d5214215c09d33c')
+
+package() {
+ install -Dm 755 "${pkgname%-bin}" -t "${pkgdir}/usr/bin"
+ install -Dm 644 "${pkgname%-bin}-$pkgver-README.md" "$pkgdir/usr/share/doc/${pkgname%-bin}/README.md"
+ install -Dm 644 "${pkgname%-bin}-$pkgver-LICENSE.md" "$pkgdir/usr/share/licenses/${pkgname%-bin}/LICENSE.md"
+ install -Dm 644 "${pkgname%-bin}-$pkgver-man.1" "$pkgdir/usr/share/man/man1/${pkgname%-bin}.1"
+}