summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbobpaul2018-03-01 14:43:02 -0600
committerbobpaul2018-03-01 14:49:41 -0600
commit6120df1f08d3a386f083b41ad33b5be990e048e0 (patch)
tree7c1e6eb313297523f7281c29b8e7ff137cb0918a
parent42af32c3186221ce7073d15bc68d24997d0d13be (diff)
downloadaur-6120df1f08d3a386f083b41ad33b5be990e048e0.tar.gz
Added conflict; moved install path; improved launcher
- launcher script handles cache folders better - conflicts with soon to be released source based package - removed "-bin" from path in /opt/
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD16
-rwxr-xr-xonelife9
3 files changed, 19 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 08407d0b91b2..f80caf51100a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = onehouronelife-bin
pkgdesc = Binary package for One Hour One Life game by Jason Rohrer
pkgver = 58
- pkgrel = 2
+ pkgrel = 3
url = http://onehouronelife.com
arch = x86_64
license = custom:Public Domain
depends = xclip
depends = lib32-sdl
+ conflicts = onehouronelife-latest
source = http://download5.onehouronelife.com/downloads/OneLife_v58_Linux.tar.gz
sha256sums = 1099672b88ab7e4e801a22a24a36195e2f59a76345224cb7e9bd73c91cea99a9
diff --git a/PKGBUILD b/PKGBUILD
index 136e4a7a681a..874fd8e3e225 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# ... there's gotta be a better way
pkgname="onehouronelife-bin"
pkgver="58"
-pkgrel=2
+pkgrel=3
epoch=
pkgdesc="Binary package for One Hour One Life game by Jason Rohrer"
arch=('x86_64')
@@ -19,7 +19,7 @@ makedepends=()
checkdepends=()
optdepends=()
provides=()
-conflicts=()
+conflicts=('onehouronelife-latest')
replaces=()
backup=()
options=()
@@ -41,6 +41,7 @@ validpgpkeys=()
prepare() {
cd $_folder
+ rm -rf settings_default >/dev/null || true
mv settings settings_default
}
@@ -53,10 +54,11 @@ prepare() {
#}
package() {
- install -dm755 $pkgdir/opt/$pkgname
- cp -r $_folder/* $pkgdir/opt/$pkgname/
- install -m755 $startdir/onelife $pkgdir/opt/$pkgname
+ instdir=${pkgname%-latest}
+ install -dm755 $pkgdir/opt/$instdir
+ cp -r $_folder/* $pkgdir/opt/$instdir/
+ install -m755 $startdir/onelife $pkgdir/opt/$instdir
install -dm755 $pkgdir/usr/local/bin
- ln -s /opt/$pkgname/onelife $pkgdir/usr/local/bin/onelife
- ln -s /opt/$pkgname/no_copyright.txt $pkgdir/opt/$pkgname/LICENSE
+ ln -s /opt/$instdir/onelife $pkgdir/usr/local/bin/onelife
+ ln -s /opt/$instdir/no_copyright.txt $pkgdir/opt/$instdir/LICENSE
}
diff --git a/onelife b/onelife
index 2ea5405c3239..a0882f956adb 100755
--- a/onelife
+++ b/onelife
@@ -10,7 +10,14 @@ if ! [[ -d ~/.config/onelife/settings ]]; then
mkdir -p ~/.config/onelife/settings >/dev/null || true
fi
-cp -n /opt/onehouronelife-bin/settings_default/* ~/.config/onelife/settings/
+## writeable stuff
+#copy cache directories so we don't have to build from scratch
+cp -rn /opt/onehouronelife/*Cache ~/.config/onelife/
+#copy settings directory
+cp -n /opt/onehouronelife/settings_default/* ~/.config/onelife/settings/
+
+## read-only stuff
+#remove all links and make new ones to everything else
find ~/.config/onelife -depth -maxdepth 1 -type l -delete
ln -st ~/.config/onelife/ $DIR/*
cd ~/.config/onelife