summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBoohbah2016-02-09 20:05:54 +0000
committerBoohbah2016-02-09 20:05:54 +0000
commit446674656668974a2655372426fb58b1cc685da4 (patch)
tree5e1b7af52837e24c80f4f003e7d26a672704035e
parent0997123e1351b3589190059684d007e80f0f8476 (diff)
downloadaur-446674656668974a2655372426fb58b1cc685da4.tar.gz
Replace with old PKGBUILD from http://pkgbuild.com/git/aur-mirror.git/tree/oneko
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD53
-rw-r--r--add-includes.patch14
3 files changed, 39 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 79d3861be70b..69bb052ea185 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
+# Generated by mksrcinfo v8
+# Tue Feb 9 20:04:28 UTC 2016
pkgbase = oneko
- pkgdesc = A modified version of oneko. KINOMOTO Sakura chases around your mouse cursor.
- pkgver = 1.2.sakura.5
- pkgrel = 1
+ pkgdesc = A cat that chases around your cursor
+ pkgver = 1.2.5
+ pkgrel = 4
url = http://www.daidouji.com/oneko/
- arch = i686
arch = x86_64
- license = Unknown
- makedepends = libxext
+ arch = i686
+ license = Public Domain
+ makedepends = imake
+ makedepends = make
+ makedepends = desktop-file-utils
depends = libx11
+ depends = libxext
source = http://www.daidouji.com/oneko/distfiles/oneko-1.2.sakura.5.tar.gz
- source = add-includes.patch
md5sums = 456b318fa6e61431bf4f0a42b110014a
- md5sums = fae2e02a36ececa2bcf13e08afa2bd95
pkgname = oneko
diff --git a/PKGBUILD b/PKGBUILD
index 363bb73f018f..93167c700c70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,38 @@
# Maintainer: Boohbah <boohbah at gmail.com>
+# Contributor: mathieui <mathieui[at]mathieui.net>
+# Contributor: rayanamukami <matthewchoi_123 at hotmail.com>
pkgname=oneko
-pkgver=1.2.sakura.5
-pkgrel=1
-pkgdesc="A modified version of oneko. KINOMOTO Sakura chases around your mouse cursor."
-arch=('i686' 'x86_64')
+pkgrel=4
+pkgver=1.2.5
+_pkgver="1.2.sakura.5"
+pkgdesc="A cat that chases around your cursor"
+arch=('x86_64' 'i686')
url="http://www.daidouji.com/oneko/"
-license=('Unknown')
-depends=('libx11')
-makedepends=('libxext')
-source=("http://www.daidouji.com/oneko/distfiles/$pkgname-$pkgver.tar.gz"
- 'add-includes.patch')
-md5sums=('456b318fa6e61431bf4f0a42b110014a'
- 'fae2e02a36ececa2bcf13e08afa2bd95')
-
-prepare() {
- cd "$pkgname-$pkgver"
- patch -p1 -i "$srcdir/add-includes.patch"
-}
+license=('Public Domain')
+depends=('libx11' 'libxext')
+makedepends=('imake' 'make' 'desktop-file-utils')
+source=("http://www.daidouji.com/$pkgname/distfiles/$pkgname-$_pkgver.tar.gz")
+md5sums=('456b318fa6e61431bf4f0a42b110014a')
build() {
- cd "$pkgname-$pkgver"
- gcc -lm -lX11 -o oneko oneko.c
+ cd "$srcdir/$pkgname-$_pkgver/"
+ xmkmf -a
+ make
}
package() {
- cd "$pkgname-$pkgver"
- install -Dm755 oneko "$pkgdir/usr/bin/oneko"
- install -Dm644 oneko.man "$pkgdir/usr/share/man/man6/oneko.6"
- mkdir "$pkgdir/usr/share/oneko"
- cp -a bitmaps bitmasks cursors "$pkgdir/usr/share/oneko"
-}
+ cd "$srcdir/$pkgname-$_pkgver/"
+ _mandir="$pkgdir/usr/share/man"
-# vim:set ts=2 sw=2 et:
+ mkdir -p "$_mandir/man1/"
+ mkdir -p "$_mandir/jp/man1/"
+ mkdir -p "$pkgdir/usr/bin"
+
+ make DESTDIR=$pkgdir install
+
+ cp oneko.man "$_mandir/man1/oneko.1"
+ cp oneko.man.jp "$_mandir/jp/man1/oneko.1"
+ echo -e '#!/bin/sh'"\nxsetroot -cursor_name top_left_arrow || xsetroot -cursor_name left_ptr " > "$pkgdir/usr/bin/oneko-restore-cursor"
+ chmod +x "$pkgdir/usr/bin/oneko-restore-cursor"
+}
diff --git a/add-includes.patch b/add-includes.patch
deleted file mode 100644
index 007960efe874..000000000000
--- a/add-includes.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/oneko.c b/oneko.c
-index d2b81fe..b7e5e49 100644
---- a/oneko.c
-+++ b/oneko.c
-@@ -6,6 +6,9 @@
- static char rcsid[] = "$Header: /home/sun/unix/kato/xsam/oneko/oneko.c,v 1.5 90/10/19 21:25:16 kato Exp $";
- #endif
-
-+#include <X11/Xlib.h>
-+#include <math.h>
-+
- #include "oneko.h"
- #include "patchlevel.h"
- /*