summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Konarev2015-06-09 20:52:58 +0300
committerAlexander Konarev2015-06-09 20:52:58 +0300
commitbe8dab8ccb9518f75bbe69ea679fd36c10c415e8 (patch)
tree263b126415e8a258b545937712179d7b73d31e28
downloadaur-be8dab8ccb9518f75bbe69ea679fd36c10c415e8.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD39
-rw-r--r--oscript2
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1499e0ad0ba2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = onescript
+ pkgdesc = This project is an alternative implementation of the virtual machine, execute scripts in the language of the 1C:Enterprise
+ pkgver = 1.0.9
+ pkgrel = 1
+ url = https://bitbucket.org/EvilBeaver/1script
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ license = LGPL3
+ depends = mono
+ noextract = OneScript-1.0.9-bin.zip
+ source = https://bitbucket.org/EvilBeaver/1script/downloads/OneScript-1.0.9-bin.zip
+ source = https://bitbucket.org/EvilBeaver/1script/wiki/attachments/snake.os
+ source = oscript
+ md5sums = c4a3a16290c4ee594b1b6114cec3d3ba
+ md5sums = e88df2f8a75ee97859839b3f45fe7e0a
+ md5sums = d0c25bfc717401e9806a7612581f6995
+
+pkgname = onescript
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88abb96b66bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Alexander Konarev <avkonarev@gmail.com>
+# Author: Andrey Ovsankin aka EvilBeaver
+pkgname=onescript
+pkgver=1.0.9
+pkgrel=1
+pkgdesc="This project is an alternative implementation of the virtual machine, execute scripts in the language of the 1C:Enterprise"
+arch=("i686" "x86_64")
+license=('GPL3' 'LGPL3')
+url="https://bitbucket.org/EvilBeaver/1script"
+depends=('mono')
+makedepens=('unzip')
+
+source=(
+ "https://bitbucket.org/EvilBeaver/1script/downloads/OneScript-$pkgver-bin.zip"
+ "https://bitbucket.org/EvilBeaver/1script/wiki/attachments/snake.os"
+ "oscript"
+ )
+noextract=("OneScript-$pkgver-bin.zip")
+
+md5sums=('c4a3a16290c4ee594b1b6114cec3d3ba'
+ 'e88df2f8a75ee97859839b3f45fe7e0a'
+ 'd0c25bfc717401e9806a7612581f6995')
+
+prepare() {
+ cd $srcdir
+ unzip OneScript-$pkgver-bin.zip -d OneScript-$pkgver
+}
+
+package() {
+ cd $srcdir
+ install -Dm755 oscript "$pkgdir/usr/bin/oscript"
+
+ install -d "$pkgdir/usr/share/oscript/examples"
+ install -Dm644 snake.os "$pkgdir/usr/share/oscript/examples"
+
+ cd $srcdir/OneScript-$pkgver/
+ install -d "$pkgdir/usr/lib/oscript"
+ install -Dm644 * "$pkgdir/usr/lib/oscript"
+}
diff --git a/oscript b/oscript
new file mode 100644
index 000000000000..d116c18cbf88
--- /dev/null
+++ b/oscript
@@ -0,0 +1,2 @@
+#! /bin/bash
+mono /usr/lib/oscript/oscript.exe "$@"