summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-07-21 08:04:22 +1200
committercaltlgin2020-07-21 08:04:22 +1200
commit3657269beeeb25625f0c9025a6d587376d457013 (patch)
tree2759eb040294707c2d2db117704b96fb7fdd16a9
downloadaur-3657269beeeb25625f0c9025a6d587376d457013.tar.gz
Add to AUR
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f1e97c259c1b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = oneshot-bin
+ pkgdesc = Easily transfer files to and from your terminal and any browser
+ pkgver = 1.1.3
+ pkgrel = 1
+ url = https://github.com/raphaelreyna/oneshot
+ arch = x86_64
+ license = MIT
+ provides = oneshot
+ noextract = oneshot-1.1.3.tar.gz
+ source = oneshot-1.1.3.tar.gz::https://github.com/raphaelreyna/oneshot/releases/download/v1.1.3/oneshot_1.1.3.linux-x86_64.tar.gz
+ sha256sums = 2cc34898b9ac2852e225f65c0158acc3534448f10603928f4d3bcca2cfcb7cee
+
+pkgname = oneshot-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..315731a577ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+_pkgname=oneshot
+pkgname=${_pkgname}-bin
+pkgver=1.1.3
+pkgrel=1
+pkgdesc='Easily transfer files to and from your terminal and any browser'
+arch=('x86_64')
+url='https://github.com/raphaelreyna/oneshot'
+license=('MIT')
+provides=("${_pkgname}")
+source=("${_pkgname}-${pkgver}.tar.gz::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}.linux-x86_64.tar.gz")
+noextract=("${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('2cc34898b9ac2852e225f65c0158acc3534448f10603928f4d3bcca2cfcb7cee')
+
+prepare() {
+ # Avoid archive contents being extracted directly into srcdir
+ install -d "${_pkgname}-${pkgver}"
+ tar -xf "${_pkgname}-${pkgver}.tar.gz" --directory "${_pkgname}-${pkgver}"
+}
+
+package() {
+ install -Dm755 "${_pkgname}-${pkgver}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm644 "${_pkgname}-${pkgver}/README.md" "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
+ install -Dm644 "${_pkgname}-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: