summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-09-08 07:30:59 +1200
committercaltlgin2020-09-08 07:30:59 +1200
commitdf628b9f4905f0a27ba68232b2a82a329e62af1a (patch)
treee3b4460c8ee7f69cc4214d0c894c4da592de2e06
parent5dd5a25b86aa4f94ddefe58e610d83e6840f8a8b (diff)
downloadaur-df628b9f4905f0a27ba68232b2a82a329e62af1a.tar.gz
Add arch armv7h and aarch64
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
2 files changed, 19 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5369d5c361e..7e9413e4a985 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,10 +4,16 @@ pkgbase = oneshot-bin
pkgrel = 1
url = https://github.com/raphaelreyna/oneshot
arch = x86_64
+ arch = armv7h
+ arch = aarch64
license = MIT
provides = oneshot
- source = oneshot-1.2.0.tar.gz::https://github.com/raphaelreyna/oneshot/releases/download/v1.2.0/oneshot_1.2.0.linux-x86_64.tar.gz
- sha256sums = eea35b2ff2f166c397ccf754a2b0af9b32793f8f5553473ded0109d579bec2ed
+ source_x86_64 = oneshot-1.2.0.tar.gz::https://github.com/raphaelreyna/oneshot/releases/download/v1.2.0/oneshot_1.2.0.linux-x86_64.tar.gz
+ sha256sums_x86_64 = eea35b2ff2f166c397ccf754a2b0af9b32793f8f5553473ded0109d579bec2ed
+ source_armv7h = oneshot-1.2.0.tar.gz::https://github.com/raphaelreyna/oneshot/releases/download/v1.2.0/oneshot_1.2.0.linux-arm.tar.gz
+ sha256sums_armv7h = 7c9a7abc3ec2ca29ee07b4c98f67ffd63fa287226a3ea699fa0392b2160f097f
+ source_aarch64 = oneshot-1.2.0.tar.gz::https://github.com/raphaelreyna/oneshot/releases/download/v1.2.0/oneshot_1.2.0.linux-arm64.tar.gz
+ sha256sums_aarch64 = 2dfe8f5ffbe0197e18c09ae9d40220403ee61ca0f8de4e66d83aa3cdf1ce496a
pkgname = oneshot-bin
diff --git a/PKGBUILD b/PKGBUILD
index df4250d22ec0..584540885b73 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,22 @@
# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
-_pkgname=oneshot
-pkgname=${_pkgname}-bin
+_pkgname='oneshot'
+pkgname="${_pkgname}-bin"
pkgver=1.2.0
pkgrel=1
pkgdesc='Easily transfer files to and from your terminal and any browser'
-arch=('x86_64')
+arch=('x86_64' 'armv7h' 'aarch64')
url='https://github.com/raphaelreyna/oneshot'
license=('MIT')
provides=("${_pkgname}")
-source=("${_pkgname}-${pkgver}.tar.gz::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}.linux-x86_64.tar.gz")
-sha256sums=('eea35b2ff2f166c397ccf754a2b0af9b32793f8f5553473ded0109d579bec2ed')
+
+source_x86_64=("${_pkgname}-${pkgver}.tar.gz::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}.linux-x86_64.tar.gz")
+source_armv7h=("${_pkgname}-${pkgver}.tar.gz::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}.linux-arm.tar.gz")
+source_aarch64=("${_pkgname}-${pkgver}.tar.gz::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}.linux-arm64.tar.gz")
+
+sha256sums_x86_64=('eea35b2ff2f166c397ccf754a2b0af9b32793f8f5553473ded0109d579bec2ed')
+sha256sums_armv7h=('7c9a7abc3ec2ca29ee07b4c98f67ffd63fa287226a3ea699fa0392b2160f097f')
+sha256sums_aarch64=('2dfe8f5ffbe0197e18c09ae9d40220403ee61ca0f8de4e66d83aa3cdf1ce496a')
package() {
install -Dm755 -t "${pkgdir}/usr/bin" "${_pkgname}"