summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2023-07-22 19:55:54 +0200
committerFabioLolix2023-07-22 19:55:54 +0200
commit2fd79f9ed8c6969442198b7ee9f391268e71c7a7 (patch)
tree04d55855ea2e17a2a77f7ba5c25290cc18502fb6
downloadaur-2fd79f9ed8c6969442198b7ee9f391268e71c7a7.tar.gz
v2019_U6
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD47
-rw-r--r--onetbb-2019-gcc12.patch68
-rw-r--r--onetbb-2019-gcc13.patch12
4 files changed, 145 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77ca8a195920
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = onetbb-2019
+ pkgdesc = High level abstract threading library (oneAPI Threading Building Blocks)
+ pkgver = 2019_U6
+ pkgrel = 1
+ url = https://oneapi-src.github.io/oneTBB/
+ arch = x86_64
+ license = Apache
+ makedepends = cmake
+ depends = glibc
+ depends = gcc-libs
+ source = onetbb-2019_U6.tar.gz::https://github.com/oneapi-src/oneTBB/archive/refs/tags/2019_U6.tar.gz
+ source = onetbb-2019-gcc12.patch
+ source = onetbb-2019-gcc13.patch
+ sha512sums = 6bcc014ec90cd62293811ac436eab03c7f7c7e3e03109efcab1c42cfed48d8bf83073d03ab381e5e63ee8c905f1792a7fdab272ec7e585df14102bad714ffc15
+ sha512sums = 36e42247c67e44765c2d0c64e5835ff47cb4e44866d7f78664e139fdf2d71284e36ea9cd902a739bd4b5134f1731222117653b918a5a1fb4f175a468af76074d
+ sha512sums = e9d4d37b6243b32dc4dbf1ab8b5b1c6a2ceb87a81b7ac711afd95244131ac5305e2369b93581c4670ca15f8cdc42482a8cd373e22779322d52e66e2a5ecdf08b
+
+pkgname = onetbb-2019
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f216b577f4a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Thiago O. Maciel <maciel at tutanota.com>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
+# Contributor: Thomas Dziedzic < gostrc at gmail >
+# Contributor: Denis Martinez <deuns.martinez AT gmail.com>
+# Contributor: Bogdan Burlacu <bogdan.burlacu AT pm.me>
+
+pkgname=onetbb-2019
+pkgver=2019_U6
+pkgrel=1
+pkgdesc="High level abstract threading library (oneAPI Threading Building Blocks)"
+arch=(x86_64)
+url="https://oneapi-src.github.io/oneTBB/"
+license=(Apache)
+depends=(glibc gcc-libs)
+makedepends=(cmake) #'inetutils'
+source=("onetbb-${pkgver}.tar.gz::https://github.com/oneapi-src/oneTBB/archive/refs/tags/${pkgver}.tar.gz"
+ 'onetbb-2019-gcc12.patch'
+ 'onetbb-2019-gcc13.patch')
+sha512sums=('6bcc014ec90cd62293811ac436eab03c7f7c7e3e03109efcab1c42cfed48d8bf83073d03ab381e5e63ee8c905f1792a7fdab272ec7e585df14102bad714ffc15'
+ '36e42247c67e44765c2d0c64e5835ff47cb4e44866d7f78664e139fdf2d71284e36ea9cd902a739bd4b5134f1731222117653b918a5a1fb4f175a468af76074d'
+ 'e9d4d37b6243b32dc4dbf1ab8b5b1c6a2ceb87a81b7ac711afd95244131ac5305e2369b93581c4670ca15f8cdc42482a8cd373e22779322d52e66e2a5ecdf08b')
+
+prepare() {
+ cd "oneTBB-${pkgver}"
+ patch -Np1 -i ../onetbb-2019-gcc12.patch
+ patch -Np1 -i ../onetbb-2019-gcc13.patch
+}
+
+build() {
+ cd "oneTBB-${pkgver}"
+ make
+}
+
+package() {
+ cd "oneTBB-${pkgver}"
+ install -Dm755 build/linux_*/*.so* -t "$pkgdir"/opt/tbb2019/lib
+ install -d "$pkgdir"/opt/tbb2019/include
+ cp -a include/tbb "$pkgdir"/opt/tbb2019/include
+ cmake \
+ -DINSTALL_DIR="$pkgdir"/opt/tbb2019/cmake \
+ -DSYSTEM_NAME=Linux \
+ -DTBB_VERSION_FILE="$pkgdir"/opt/tbb2019/include/tbb/tbb_stddef.h \
+ -P cmake/tbb_config_installer.cmake
+}
+
diff --git a/onetbb-2019-gcc12.patch b/onetbb-2019-gcc12.patch
new file mode 100644
index 000000000000..09be0e026bd8
--- /dev/null
+++ b/onetbb-2019-gcc12.patch
@@ -0,0 +1,68 @@
+From 2d5f33dd83534bbfadbe59d8ce19b6bb983ec097 Mon Sep 17 00:00:00 2001
+From: qumaciel <maciel@tutanota.com>
+Date: Fri, 19 Aug 2022 17:50:37 -0300
+Subject: gcc12
+
+---
+ build/linux.gcc.inc | 36 ++++++++++++++++++------------------
+ 1 file changed, 18 insertions(+), 18 deletions(-)
+
+diff --git a/build/linux.gcc.inc b/build/linux.gcc.inc
+index aef54f5..0c9e738 100644
+--- a/build/linux.gcc.inc
++++ b/build/linux.gcc.inc
+@@ -36,33 +36,33 @@ LINK_FLAGS = -Wl,-rpath-link=. -rdynamic
+ C_FLAGS = $(CPLUS_FLAGS)
+
+ # gcc 4.2 and higher support OpenMP
+-ifneq (,$(shell $(CONLY) -dumpversion | egrep "^(4\.[2-9]|[5-9])"))
+- OPENMP_FLAG = -fopenmp
+-endif
++# ifneq (,$(shell $(CONLY) -dumpversion | egrep "^(4\.[2-9]|[5-9])"))
++OPENMP_FLAG = -fopenmp
++# endif
+
+ # gcc 4.8 and later support RTM intrinsics, but require command line switch to enable them
+-ifneq (,$(shell $(CONLY) -dumpversion | egrep "^(4\.[8-9]|[5-9])"))
+- RTM_KEY = -mrtm
+-endif
++# ifneq (,$(shell $(CONLY) -dumpversion | egrep "^(4\.[8-9]|[5-9])"))
++RTM_KEY = -mrtm
++# endif
+
+ # gcc 4.0 and later have -Wextra that is used by some our customers.
+-ifneq (,$(shell $(CONLY) -dumpversion | egrep "^([4-9])"))
+- WARNING_KEY += -Wextra
+-endif
++# ifneq (,$(shell $(CONLY) -dumpversion | egrep "^([4-9])"))
++WARNING_KEY += -Wextra
++# endif
+
+ # gcc 5.0 and later have -Wsuggest-override and -Wno-sized-deallocation options
+-ifneq (,$(shell $(CONLY) -dumpversion | egrep "^([5-9])"))
+- # enable -Wsuggest-override via a pre-included header in order to limit to C++11 and above
+- INCLUDE_TEST_HEADERS = -include $(tbb_root)/src/test/harness_preload.h
+- WARNING_SUPPRESS += -Wno-sized-deallocation
+-endif
++# ifneq (,$(shell $(CONLY) -dumpversion | egrep "^([5-9])"))
++# enable -Wsuggest-override via a pre-included header in order to limit to C++11 and above
++INCLUDE_TEST_HEADERS = -include $(tbb_root)/src/test/harness_preload.h
++WARNING_SUPPRESS += -Wno-sized-deallocation
++# endif
+
+ # gcc 6.0 and later have -flifetime-dse option that controls
+ # elimination of stores done outside the object lifetime
+-ifneq (,$(shell $(CONLY) -dumpversion | egrep "^([6-9])"))
+- # keep pre-contruction stores for zero initialization
+- DSE_KEY = -flifetime-dse=1
+-endif
++# ifneq (,$(shell $(CONLY) -dumpversion | egrep "^([6-9])"))
++# keep pre-contruction stores for zero initialization
++DSE_KEY = -flifetime-dse=1
++# endif
+
+ ifeq ($(cfg), release)
+ CPLUS_FLAGS = $(ITT_NOTIFY) -g -O2 -DUSE_PTHREAD
+--
+2.37.2
+
diff --git a/onetbb-2019-gcc13.patch b/onetbb-2019-gcc13.patch
new file mode 100644
index 000000000000..3bf842a6d2d7
--- /dev/null
+++ b/onetbb-2019-gcc13.patch
@@ -0,0 +1,12 @@
+diff --git a/include/tbb/task.h b/include/tbb/task.h
+index 8498b20..195f836 100644
+--- a/include/tbb/task.h
++++ b/include/tbb/task.h
+@@ -230,7 +230,7 @@ namespace internal {
+ #if __TBB_TASK_PRIORITY
+ //! Pointer to the next offloaded lower priority task.
+ /** Used to maintain a list of offloaded tasks inside the scheduler. **/
+- task* next_offloaded;
++ tbb::task* next_offloaded;
+ };
+ #endif /* __TBB_TASK_PRIORITY */