summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeff Parent2015-06-15 23:46:00 -0500
committerJeff Parent2015-06-15 23:47:00 -0500
commit0ad6ad8deae31fb06c19375ae82855c0657a1ec6 (patch)
tree0b83e5dd318b07456abc9396ec312a1d908d872d
downloadaur-0ad6ad8deae31fb06c19375ae82855c0657a1ec6.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cca296fdb6d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = onetime
+ pkgdesc = an open source encrpyiont program that uses the one-time pad method.
+ pkgver = 1.81
+ pkgrel = 2
+ url = http://red-bean.com/onetime/
+ arch = any
+ license = MIT
+ depends = python2
+ provides = onetime
+ source = http://red-bean.com/onetime/onetime-1.81.tar.gz
+ sha256sums = 36a83a83ac9f4018278bf48e868af00f3326b853229fae7e43b38d167e628348
+
+pkgname = onetime
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3f56c13161ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Jeff Parent <jecxjo@sdf.lonestar.org>
+pkgname=onetime
+pkgver=1.81
+pkgrel=2
+epoch=
+pkgdesc="an open source encrpyiont program that uses the one-time pad method."
+arch=(any)
+url="http://red-bean.com/onetime/"
+license=('MIT')
+depends=(python2)
+provides=(onetime)
+source=(http://red-bean.com/onetime/$pkgname-$pkgver.tar.gz)
+sha256sums=('36a83a83ac9f4018278bf48e868af00f3326b853229fae7e43b38d167e628348')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i 's/python/python2/' ./onetime
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -d $pkgdir/usr/bin
+ install -m 555 onetime $pkgdir/usr/bin
+}