summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornulldev2021-10-26 10:42:36 -0400
committernulldev2021-10-26 10:42:36 -0400
commit92c3a01c6867210c1f550eb66bf489bdd33ff30c (patch)
tree509a87d6f2644a7957dc213e4ca9ebcca8dbc441
downloadaur-92c3a01c6867210c1f550eb66bf489bdd33ff30c.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b3607c5d5d6e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = onetun
+ pkgdesc = Access your WireGuard network from any device, without root access or having to install WireGuard locally.
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/aramperes/onetun
+ arch = x86_64
+ arch = i686
+ arch = pentium4
+ arch = aarch64
+ arch = armv7h
+ arch = armv6h
+ license = MIT
+ makedepends = cargo
+ source = https://github.com/aramperes/onetun/archive/v0.2.1.tar.gz
+ sha256sums = 3e5e025104be2c601a7b4d528adae0b0fc98ff99f098d5b5d8d6a6ae70d61d58
+
+pkgname = onetun
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc633c6c8182
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Andy Bao <contact at andybao dot me>
+pkgname=onetun
+pkgdesc="Access your WireGuard network from any device, without root access or having to install WireGuard locally."
+pkgver=0.2.1
+pkgrel=1
+arch=('x86_64' 'i686' 'pentium4' 'aarch64' 'armv7h' 'armv6h')
+url="https://github.com/aramperes/onetun"
+license=('MIT')
+makedepends=('cargo')
+source=("$url/archive/v$pkgver.tar.gz")
+sha256sums=('3e5e025104be2c601a7b4d528adae0b0fc98ff99f098d5b5d8d6a6ae70d61d58')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release --locked --target-dir=target
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ mkdir -p "$pkgdir/usr/bin/"
+ install -Dm755 "target/release/onetun" "$pkgdir/usr/bin/onetun"
+}