summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-08-14 01:40:44 -0300
committerDaniel Bermond2022-08-14 01:40:44 -0300
commit101100527d563ccff023a3c6cae33c99961c8e35 (patch)
tree25ed2a77335014b11ce4d54b639e007c743f62f9
parentc3aa25867279741e0160dcc807cb6b9524409589 (diff)
downloadaur-101100527d563ccff023a3c6cae33c99961c8e35.tar.gz
Enable lto on dependencies. Cosmetic changes.
-rw-r--r--.SRCINFO4
-rw-r--r--010-onevpl-cpu-fix-build.patch12
-rw-r--r--PKGBUILD15
3 files changed, 12 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c6dfe89f7db..0ed2fb730122 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = onevpl-cpu
pkgdesc = oneVPL runtime implementation for CPU
pkgver = 2022.2.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.intel.com/content/www/us/en/developer/tools/oneapi/onevpl.html
arch = x86_64
license = MIT
@@ -18,6 +18,6 @@ pkgbase = onevpl-cpu
source = https://github.com/oneapi-src/oneVPL-cpu/archive/v2022.2.1/onevpl-cpu-2022.2.1.tar.gz
source = 010-onevpl-cpu-fix-build.patch
sha256sums = f56ee98343ab97be080dadb6346cf433ef0610db8ad6c9e45bba80930aa677a1
- sha256sums = f8a04899239250cd32edde782823cf76be46249a17c3147fc29f3742a21f710c
+ sha256sums = b3d77713f62240140fe743e2bf6cd747469c8c070b18f31f0efc572c68af20ca
pkgname = onevpl-cpu
diff --git a/010-onevpl-cpu-fix-build.patch b/010-onevpl-cpu-fix-build.patch
index 39a05c1fe589..da30d28020fa 100644
--- a/010-onevpl-cpu-fix-build.patch
+++ b/010-onevpl-cpu-fix-build.patch
@@ -1,15 +1,5 @@
--- a/script/bootstrap.py
+++ b/script/bootstrap.py
-@@ -546,7 +546,8 @@ def build_dav1d_decoder(install_dir):
- cmd('meson', 'build', '--prefix', os.path.join(install_dir,
- ''), '--libdir',
- os.path.join(install_dir, 'lib'), '--buildtype', 'release',
-- '--default-library=static', '-Denable_avx512=false')
-+ '--default-library=static', '-Denable_avx512=false',
-+ '-Dc_args=${CFLAGS} -fno-lto', '-Dcpp_args=${CXXFLAGS} -fno-lto')
- cmd('ninja', '-C', 'build')
- with pushd('build'):
- cmd('ninja', 'install')
@@ -662,6 +663,7 @@ def build_gpl_x264_encoder(install_dir):
f'--prefix={posix_install_dir}',
'--enable-static',
@@ -22,7 +12,7 @@
'--enable-filter=select',
'--enable-filter=concat',
'--enable-filter=ssim',
-+ '--extra-cflags=-fno-lto',
++ '--enable-lto',
]
if os.name == 'nt':
result.extend([
diff --git a/PKGBUILD b/PKGBUILD
index 2fbfba7f619a..41eccff365f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=onevpl-cpu
pkgver=2022.2.1
-pkgrel=1
+pkgrel=2
pkgdesc='oneVPL runtime implementation for CPU'
arch=('x86_64')
url='https://www.intel.com/content/www/us/en/developer/tools/oneapi/onevpl.html'
@@ -13,7 +13,7 @@ provides=('onevpl-runtime')
source=("https://github.com/oneapi-src/oneVPL-cpu/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz"
'010-onevpl-cpu-fix-build.patch')
sha256sums=('f56ee98343ab97be080dadb6346cf433ef0610db8ad6c9e45bba80930aa677a1'
- 'f8a04899239250cd32edde782823cf76be46249a17c3147fc29f3742a21f710c')
+ 'b3d77713f62240140fe743e2bf6cd747469c8c070b18f31f0efc572c68af20ca')
prepare() {
patch -d "oneVPL-cpu-${pkgver}" -Np1 -i "${srcdir}/010-onevpl-cpu-fix-build.patch"
@@ -22,19 +22,22 @@ prepare() {
build() {
export CFLAGS+=' -ffat-lto-objects'
export CXXFLAGS+=' -ffat-lto-objects'
- local -x PKG_CONFIG_LIBDIR="${srcdir}/install-deps/lib"
- local -x VPL_BUILD_DEPENDENCIES="${srcdir}/install-deps"
+ local -x PKG_CONFIG_LIBDIR="${srcdir}/deps-install/lib"
+ local -x VPL_CPU_DEPS_BUILD_DIR="${srcdir}/deps-build"
+ local -x VPL_BUILD_DEPENDENCIES="${srcdir}/deps-install"
- . "oneVPL-cpu-${pkgver}/script/bootstrap" gpl
+ "oneVPL-cpu-${pkgver}/script/bootstrap" gpl
local _pyver
_pyver="$(python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')"
+ export CFLAGS="${CFLAGS/ -ffat-lto-objects/}"
+ export CXXFLAGS="${CXXFLAGS/ -ffat-lto-objects/}"
cmake -B build -S "oneVPL-cpu-${pkgver}" \
-DCMAKE_BUILD_TYPE:STRING='None' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
-DCMAKE_INSTALL_SYSCONFDIR:PATH='/etc' \
- -DCMAKE_PREFIX_PATH:PATH="${srcdir}/install-deps" \
+ -DCMAKE_PREFIX_PATH:PATH="${srcdir}/deps-install" \
-DBUILD_GPL_X264:BOOL='ON' \
-DBUILD_TESTS:BOOL='ON' \
-DONEAPI_INSTALL_LICENSEDIR:STRING="share/licenses/${pkgname}" \