summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2023-01-28 11:27:40 -0300
committerDaniel Bermond2023-01-28 11:27:40 -0300
commit10fb1ef69aae23a03b38530c3b12477c4a6daca1 (patch)
tree9cde796ef2e74063e8d34ac7e4f2c1e3bfccf657
parenta17f58e68ce3dce027f6048122aa0817fc0d2c04 (diff)
downloadaur-10fb1ef69aae23a03b38530c3b12477c4a6daca1.tar.gz
Update to version 2023.1.2
-rw-r--r--.SRCINFO8
-rw-r--r--020-onevpl-cpu-disable-gtest-werror.patch18
-rw-r--r--PKGBUILD13
3 files changed, 8 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ec4a81b5369..9c1161f89d12 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = onevpl-cpu
pkgdesc = oneVPL runtime implementation for CPU
- pkgver = 2023.1.1
+ pkgver = 2023.1.2
pkgrel = 1
url = https://www.intel.com/content/www/us/en/developer/tools/oneapi/onevpl.html
arch = x86_64
@@ -15,11 +15,9 @@ pkgbase = onevpl-cpu
makedepends = yasm
depends = gcc-libs
provides = onevpl-runtime
- source = https://github.com/oneapi-src/oneVPL-cpu/archive/v2023.1.1/onevpl-cpu-2023.1.1.tar.gz
+ source = https://github.com/oneapi-src/oneVPL-cpu/archive/v2023.1.2/onevpl-cpu-2023.1.2.tar.gz
source = 010-onevpl-cpu-fix-build.patch
- source = 020-onevpl-cpu-disable-gtest-werror.patch
- sha256sums = 54cef98ce56cf2d68ab0cedf84194036d484621e5cd68d502a0aac90f6b32c4b
+ sha256sums = 78608458545982354070c04802bbf77be494e9fd25c5cab9635849bcb245aff1
sha256sums = ee6b8f15e24a6c03337657c3b38eab0b929cc3ec539a94dd8d1d5f9a9b85b3cb
- sha256sums = a0caaa1dd7701b6a13ebe58bc6917c4f10f787f33d4d7e53d52766ddf985b980
pkgname = onevpl-cpu
diff --git a/020-onevpl-cpu-disable-gtest-werror.patch b/020-onevpl-cpu-disable-gtest-werror.patch
deleted file mode 100644
index ec27df214972..000000000000
--- a/020-onevpl-cpu-disable-gtest-werror.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/test/unit/googletest/googletest/cmake/internal_utils.cmake
-+++ b/test/unit/googletest/googletest/cmake/internal_utils.cmake
-@@ -82,13 +82,13 @@ macro(config_compiler_and_linker)
- # http://stackoverflow.com/questions/3232669 explains the issue.
- set(cxx_base_flags "${cxx_base_flags} -wd4702")
- elseif (CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
-- set(cxx_base_flags "-Wall -Wshadow -Werror -Wconversion")
-+ set(cxx_base_flags "-Wall -Wshadow -Wconversion")
- set(cxx_exception_flags "-fexceptions")
- set(cxx_no_exception_flags "-fno-exceptions")
- set(cxx_strict_flags "-W -Wpointer-arith -Wreturn-type -Wcast-qual -Wwrite-strings -Wswitch -Wunused-parameter -Wcast-align -Wchar-subscripts -Winline -Wredundant-decls")
- set(cxx_no_rtti_flags "-fno-rtti")
- elseif (CMAKE_COMPILER_IS_GNUCXX)
-- set(cxx_base_flags "-Wall -Wshadow -Werror")
-+ set(cxx_base_flags "-Wall -Wshadow")
- if(NOT CMAKE_CXX_COMPILER_VERSION VERSION_LESS 7.0.0)
- set(cxx_base_flags "${cxx_base_flags} -Wno-error=dangling-else")
- endif()
diff --git a/PKGBUILD b/PKGBUILD
index 5bb023602e71..27ec6912c658 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=onevpl-cpu
-pkgver=2023.1.1
+pkgver=2023.1.2
pkgrel=1
pkgdesc='oneVPL runtime implementation for CPU'
arch=('x86_64')
@@ -11,15 +11,12 @@ depends=('gcc-libs')
makedepends=('git' 'cmake' 'meson' 'nasm' 'onevpl' 'python' 'xxhash' 'yasm')
provides=('onevpl-runtime')
source=("https://github.com/oneapi-src/oneVPL-cpu/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz"
- '010-onevpl-cpu-fix-build.patch'
- '020-onevpl-cpu-disable-gtest-werror.patch')
-sha256sums=('54cef98ce56cf2d68ab0cedf84194036d484621e5cd68d502a0aac90f6b32c4b'
- 'ee6b8f15e24a6c03337657c3b38eab0b929cc3ec539a94dd8d1d5f9a9b85b3cb'
- 'a0caaa1dd7701b6a13ebe58bc6917c4f10f787f33d4d7e53d52766ddf985b980')
+ '010-onevpl-cpu-fix-build.patch')
+sha256sums=('78608458545982354070c04802bbf77be494e9fd25c5cab9635849bcb245aff1'
+ 'ee6b8f15e24a6c03337657c3b38eab0b929cc3ec539a94dd8d1d5f9a9b85b3cb')
prepare() {
patch -d "oneVPL-cpu-${pkgver}" -Np1 -i "${srcdir}/010-onevpl-cpu-fix-build.patch"
- patch -d "oneVPL-cpu-${pkgver}" -Np1 -i "${srcdir}/020-onevpl-cpu-disable-gtest-werror.patch"
}
build() {
@@ -54,5 +51,5 @@ check() {
}
package() {
- make -C build DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}