summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-12-10 13:53:45 -0300
committerDaniel Bermond2022-12-10 13:53:45 -0300
commitd2c2a7684328a93d3d186254829dfd8937898b23 (patch)
treee12828f0756c8173bef0a2d8264184f2ea28030d
parent6cc08a5fd13ca2ae35dbd37f90403f34b7c18fa8 (diff)
downloadaur-d2c2a7684328a93d3d186254829dfd8937898b23.tar.gz
Update to version 2023.1.0
-rw-r--r--.SRCINFO10
-rw-r--r--010-onevpl-cpu-fix-build.patch4
-rw-r--r--020-onevpl-cpu-disable-gtest-werror.patch18
-rw-r--r--PKGBUILD11
4 files changed, 33 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8fa135fd7888..f0d160c4766f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = onevpl-cpu
pkgdesc = oneVPL runtime implementation for CPU
- pkgver = 2022.2.4
+ pkgver = 2023.1.0
pkgrel = 1
url = https://www.intel.com/content/www/us/en/developer/tools/oneapi/onevpl.html
arch = x86_64
@@ -15,9 +15,11 @@ pkgbase = onevpl-cpu
makedepends = yasm
depends = gcc-libs
provides = onevpl-runtime
- source = https://github.com/oneapi-src/oneVPL-cpu/archive/v2022.2.4/onevpl-cpu-2022.2.4.tar.gz
+ source = https://github.com/oneapi-src/oneVPL-cpu/archive/v2023.1.0/onevpl-cpu-2023.1.0.tar.gz
source = 010-onevpl-cpu-fix-build.patch
- sha256sums = 5a236a0c366db38d8d2e64e2df2e42f355b8a46175e78977f9f150d2d5bce81c
- sha256sums = b3d77713f62240140fe743e2bf6cd747469c8c070b18f31f0efc572c68af20ca
+ source = 020-onevpl-cpu-disable-gtest-werror.patch
+ sha256sums = cc07c96345e41a6cd85b090e3eb0dca7c4022b08c4a3c9edc0049eed9293d39a
+ sha256sums = ee6b8f15e24a6c03337657c3b38eab0b929cc3ec539a94dd8d1d5f9a9b85b3cb
+ sha256sums = a0caaa1dd7701b6a13ebe58bc6917c4f10f787f33d4d7e53d52766ddf985b980
pkgname = onevpl-cpu
diff --git a/010-onevpl-cpu-fix-build.patch b/010-onevpl-cpu-fix-build.patch
index da30d28020fa..f0a75cc15978 100644
--- a/010-onevpl-cpu-fix-build.patch
+++ b/010-onevpl-cpu-fix-build.patch
@@ -1,6 +1,6 @@
--- a/script/bootstrap.py
+++ b/script/bootstrap.py
-@@ -662,6 +663,7 @@ def build_gpl_x264_encoder(install_dir):
+@@ -674,6 +674,7 @@ def build_gpl_x264_encoder(install_dir):
f'--prefix={posix_install_dir}',
'--enable-static',
'--enable-pic',
@@ -8,7 +8,7 @@
shell='bash')
cmd('make', '-j', CPU_COUNT)
cmd('make', 'install')
-@@ -785,6 +787,7 @@ def ffmpeg_configure_opts(install_dir, a
+@@ -798,6 +799,7 @@ def ffmpeg_configure_opts(install_dir, a
'--enable-filter=select',
'--enable-filter=concat',
'--enable-filter=ssim',
diff --git a/020-onevpl-cpu-disable-gtest-werror.patch b/020-onevpl-cpu-disable-gtest-werror.patch
new file mode 100644
index 000000000000..ec27df214972
--- /dev/null
+++ b/020-onevpl-cpu-disable-gtest-werror.patch
@@ -0,0 +1,18 @@
+--- a/test/unit/googletest/googletest/cmake/internal_utils.cmake
++++ b/test/unit/googletest/googletest/cmake/internal_utils.cmake
+@@ -82,13 +82,13 @@ macro(config_compiler_and_linker)
+ # http://stackoverflow.com/questions/3232669 explains the issue.
+ set(cxx_base_flags "${cxx_base_flags} -wd4702")
+ elseif (CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
+- set(cxx_base_flags "-Wall -Wshadow -Werror -Wconversion")
++ set(cxx_base_flags "-Wall -Wshadow -Wconversion")
+ set(cxx_exception_flags "-fexceptions")
+ set(cxx_no_exception_flags "-fno-exceptions")
+ set(cxx_strict_flags "-W -Wpointer-arith -Wreturn-type -Wcast-qual -Wwrite-strings -Wswitch -Wunused-parameter -Wcast-align -Wchar-subscripts -Winline -Wredundant-decls")
+ set(cxx_no_rtti_flags "-fno-rtti")
+ elseif (CMAKE_COMPILER_IS_GNUCXX)
+- set(cxx_base_flags "-Wall -Wshadow -Werror")
++ set(cxx_base_flags "-Wall -Wshadow")
+ if(NOT CMAKE_CXX_COMPILER_VERSION VERSION_LESS 7.0.0)
+ set(cxx_base_flags "${cxx_base_flags} -Wno-error=dangling-else")
+ endif()
diff --git a/PKGBUILD b/PKGBUILD
index 2877e3cff6cc..c28c57b2b82a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=onevpl-cpu
-pkgver=2022.2.4
+pkgver=2023.1.0
pkgrel=1
pkgdesc='oneVPL runtime implementation for CPU'
arch=('x86_64')
@@ -11,12 +11,15 @@ depends=('gcc-libs')
makedepends=('git' 'cmake' 'meson' 'nasm' 'onevpl' 'python' 'xxhash' 'yasm')
provides=('onevpl-runtime')
source=("https://github.com/oneapi-src/oneVPL-cpu/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz"
- '010-onevpl-cpu-fix-build.patch')
-sha256sums=('5a236a0c366db38d8d2e64e2df2e42f355b8a46175e78977f9f150d2d5bce81c'
- 'b3d77713f62240140fe743e2bf6cd747469c8c070b18f31f0efc572c68af20ca')
+ '010-onevpl-cpu-fix-build.patch'
+ '020-onevpl-cpu-disable-gtest-werror.patch')
+sha256sums=('cc07c96345e41a6cd85b090e3eb0dca7c4022b08c4a3c9edc0049eed9293d39a'
+ 'ee6b8f15e24a6c03337657c3b38eab0b929cc3ec539a94dd8d1d5f9a9b85b3cb'
+ 'a0caaa1dd7701b6a13ebe58bc6917c4f10f787f33d4d7e53d52766ddf985b980')
prepare() {
patch -d "oneVPL-cpu-${pkgver}" -Np1 -i "${srcdir}/010-onevpl-cpu-fix-build.patch"
+ patch -d "oneVPL-cpu-${pkgver}" -Np1 -i "${srcdir}/020-onevpl-cpu-disable-gtest-werror.patch"
}
build() {