summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2023-03-07 15:19:37 -0300
committerDaniel Bermond2023-03-07 15:19:37 -0300
commit2b49c393d2761771f7514f9ae4402ec80f907871 (patch)
tree682df1458ed7407935511085b0b8413ebe9f93cf
parenta4edc8684bf877b726bc114f87238e339cc82c6a (diff)
downloadaur-2b49c393d2761771f7514f9ae4402ec80f907871.tar.gz
Match latest upstream changes
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD12
2 files changed, 6 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52ab4b9967dd..e03d01e70da9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = onevpl-cpu-git
pkgdesc = oneVPL runtime implementation for CPU (git version)
- pkgver = 2023.1.2.r0.g748f32e
+ pkgver = 2023.1.3.r0.g43f9696
pkgrel = 1
url = https://www.intel.com/content/www/us/en/developer/tools/oneapi/onevpl.html
arch = x86_64
@@ -10,7 +10,6 @@ pkgbase = onevpl-cpu-git
makedepends = meson
makedepends = nasm
makedepends = onevpl
- makedepends = python
makedepends = xxhash
makedepends = yasm
depends = gcc-libs
diff --git a/PKGBUILD b/PKGBUILD
index 027930f283ac..0b86259146af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=onevpl-cpu-git
-pkgver=2023.1.2.r0.g748f32e
+pkgver=2023.1.3.r0.g43f9696
pkgrel=1
pkgdesc='oneVPL runtime implementation for CPU (git version)'
arch=('x86_64')
url='https://www.intel.com/content/www/us/en/developer/tools/oneapi/onevpl.html'
license=('MIT')
depends=('gcc-libs')
-makedepends=('git' 'cmake' 'meson' 'nasm' 'onevpl' 'python' 'xxhash' 'yasm')
+makedepends=('git' 'cmake' 'meson' 'nasm' 'onevpl' 'xxhash' 'yasm')
provides=('onevpl-cpu' 'onevpl-runtime')
conflicts=('onevpl-cpu')
source=('git+https://github.com/oneapi-src/oneVPL-cpu.git'
@@ -33,12 +33,11 @@ build() {
oneVPL-cpu/script/bootstrap gpl
- local _pyver
- _pyver="$(python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')"
export CFLAGS="${CFLAGS/ -ffat-lto-objects/}"
export CXXFLAGS="${CXXFLAGS/ -ffat-lto-objects/}"
cmake -B build -S oneVPL-cpu \
+ -G 'Unix Makefiles' \
-DCMAKE_BUILD_TYPE:STRING='None' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
-DCMAKE_INSTALL_SYSCONFDIR:PATH='/etc' \
@@ -46,13 +45,12 @@ build() {
-DBUILD_GPL_X264:BOOL='ON' \
-DBUILD_TESTS:BOOL='ON' \
-DONEAPI_INSTALL_LICENSEDIR:STRING="share/licenses/${pkgname}" \
- -DONEAPI_INSTALL_PYTHONDIR:STRING="lib/python${_pyver}" \
-Wno-dev
- make -C build
+ cmake --build build
}
check() {
- make -C build test
+ ctest --test-dir build --output-on-failure
}
package() {