summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-12-10 13:54:13 -0300
committerDaniel Bermond2022-12-10 13:54:13 -0300
commite31bba78e7b05aeba59c7fe47911c880338d8c0e (patch)
treee5c2807f2f96e7c02ea6e6c561dc3fe8c5b8d491
parent19d3dfc04984d45a9faf8b503d991bb6ee9d2440 (diff)
downloadaur-e31bba78e7b05aeba59c7fe47911c880338d8c0e.tar.gz
Match latest upstream changes
-rw-r--r--.SRCINFO6
-rw-r--r--010-onevpl-cpu-fix-build.patch4
-rw-r--r--020-onevpl-cpu-disable-gtest-werror.patch18
-rw-r--r--PKGBUILD9
4 files changed, 30 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e75a422e44c..4d8cd4b84ea3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = onevpl-cpu-git
pkgdesc = oneVPL runtime implementation for CPU (git version)
- pkgver = 2022.2.1.r0.ga091605
+ pkgver = 2023.1.0.r0.g2c8c32a
pkgrel = 1
url = https://www.intel.com/content/www/us/en/developer/tools/oneapi/onevpl.html
arch = x86_64
@@ -19,7 +19,9 @@ pkgbase = onevpl-cpu-git
conflicts = onevpl-cpu
source = git+https://github.com/oneapi-src/oneVPL-cpu.git
source = 010-onevpl-cpu-fix-build.patch
+ source = 020-onevpl-cpu-disable-gtest-werror.patch
sha256sums = SKIP
- sha256sums = b3d77713f62240140fe743e2bf6cd747469c8c070b18f31f0efc572c68af20ca
+ sha256sums = ee6b8f15e24a6c03337657c3b38eab0b929cc3ec539a94dd8d1d5f9a9b85b3cb
+ sha256sums = a0caaa1dd7701b6a13ebe58bc6917c4f10f787f33d4d7e53d52766ddf985b980
pkgname = onevpl-cpu-git
diff --git a/010-onevpl-cpu-fix-build.patch b/010-onevpl-cpu-fix-build.patch
index da30d28020fa..f0a75cc15978 100644
--- a/010-onevpl-cpu-fix-build.patch
+++ b/010-onevpl-cpu-fix-build.patch
@@ -1,6 +1,6 @@
--- a/script/bootstrap.py
+++ b/script/bootstrap.py
-@@ -662,6 +663,7 @@ def build_gpl_x264_encoder(install_dir):
+@@ -674,6 +674,7 @@ def build_gpl_x264_encoder(install_dir):
f'--prefix={posix_install_dir}',
'--enable-static',
'--enable-pic',
@@ -8,7 +8,7 @@
shell='bash')
cmd('make', '-j', CPU_COUNT)
cmd('make', 'install')
-@@ -785,6 +787,7 @@ def ffmpeg_configure_opts(install_dir, a
+@@ -798,6 +799,7 @@ def ffmpeg_configure_opts(install_dir, a
'--enable-filter=select',
'--enable-filter=concat',
'--enable-filter=ssim',
diff --git a/020-onevpl-cpu-disable-gtest-werror.patch b/020-onevpl-cpu-disable-gtest-werror.patch
new file mode 100644
index 000000000000..ec27df214972
--- /dev/null
+++ b/020-onevpl-cpu-disable-gtest-werror.patch
@@ -0,0 +1,18 @@
+--- a/test/unit/googletest/googletest/cmake/internal_utils.cmake
++++ b/test/unit/googletest/googletest/cmake/internal_utils.cmake
+@@ -82,13 +82,13 @@ macro(config_compiler_and_linker)
+ # http://stackoverflow.com/questions/3232669 explains the issue.
+ set(cxx_base_flags "${cxx_base_flags} -wd4702")
+ elseif (CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
+- set(cxx_base_flags "-Wall -Wshadow -Werror -Wconversion")
++ set(cxx_base_flags "-Wall -Wshadow -Wconversion")
+ set(cxx_exception_flags "-fexceptions")
+ set(cxx_no_exception_flags "-fno-exceptions")
+ set(cxx_strict_flags "-W -Wpointer-arith -Wreturn-type -Wcast-qual -Wwrite-strings -Wswitch -Wunused-parameter -Wcast-align -Wchar-subscripts -Winline -Wredundant-decls")
+ set(cxx_no_rtti_flags "-fno-rtti")
+ elseif (CMAKE_COMPILER_IS_GNUCXX)
+- set(cxx_base_flags "-Wall -Wshadow -Werror")
++ set(cxx_base_flags "-Wall -Wshadow")
+ if(NOT CMAKE_CXX_COMPILER_VERSION VERSION_LESS 7.0.0)
+ set(cxx_base_flags "${cxx_base_flags} -Wno-error=dangling-else")
+ endif()
diff --git a/PKGBUILD b/PKGBUILD
index 6507a402593c..08f5853c9308 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=onevpl-cpu-git
-pkgver=2022.2.1.r0.ga091605
+pkgver=2023.1.0.r0.g2c8c32a
pkgrel=1
pkgdesc='oneVPL runtime implementation for CPU (git version)'
arch=('x86_64')
@@ -12,12 +12,15 @@ makedepends=('git' 'cmake' 'meson' 'nasm' 'onevpl' 'python' 'xxhash' 'yasm')
provides=('onevpl-cpu' 'onevpl-runtime')
conflicts=('onevpl-cpu')
source=('git+https://github.com/oneapi-src/oneVPL-cpu.git'
- '010-onevpl-cpu-fix-build.patch')
+ '010-onevpl-cpu-fix-build.patch'
+ '020-onevpl-cpu-disable-gtest-werror.patch')
sha256sums=('SKIP'
- 'b3d77713f62240140fe743e2bf6cd747469c8c070b18f31f0efc572c68af20ca')
+ 'ee6b8f15e24a6c03337657c3b38eab0b929cc3ec539a94dd8d1d5f9a9b85b3cb'
+ 'a0caaa1dd7701b6a13ebe58bc6917c4f10f787f33d4d7e53d52766ddf985b980')
prepare() {
patch -d oneVPL-cpu -Np1 -i "${srcdir}/010-onevpl-cpu-fix-build.patch"
+ patch -d oneVPL-cpu -Np1 -i "${srcdir}/020-onevpl-cpu-disable-gtest-werror.patch"
}
pkgver() {