summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-05-30 17:26:33 -0300
committerDaniel Bermond2022-05-30 17:26:33 -0300
commit22db532387c0736e87e4701cbc862a2bfc3c0bdf (patch)
tree4ccbf4f624fe19b03dca7333e2a4d50c35e0e756
parent785336f4e48ecde216cbe076feb64fd49ad3c206 (diff)
downloadaur-22db532387c0736e87e4701cbc862a2bfc3c0bdf.tar.gz
Match latest upstream changes
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de80703c4d87..d90355c59905 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = onevpl-git
pkgdesc = oneAPI Video Processing Library (git version)
- pkgver = 2022.0.1.r1.g43c3736
+ pkgver = 2022.1.4.r0.g8f6d55d
pkgrel = 1
url = https://software.intel.com/content/www/us/en/develop/tools/oneapi/components/onevpl.html
arch = x86_64
@@ -11,6 +11,7 @@ pkgbase = onevpl-git
makedepends = pybind11
makedepends = python
makedepends = libx11
+ makedepends = wayland-protocols
depends = libva
optdepends = onevpl-runtime: for runtime implementation
optdepends = python: for python bindings
diff --git a/PKGBUILD b/PKGBUILD
index 95c2a7b2808a..db85c36847be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=onevpl-git
-pkgver=2022.0.1.r1.g43c3736
+pkgver=2022.1.4.r0.g8f6d55d
pkgrel=1
pkgdesc='oneAPI Video Processing Library (git version)'
arch=('x86_64')
@@ -10,7 +10,7 @@ license=('MIT')
depends=('libva')
optdepends=('onevpl-runtime: for runtime implementation'
'python: for python bindings')
-makedepends=('git' 'cmake' 'libdrm' 'pybind11' 'python' 'libx11')
+makedepends=('git' 'cmake' 'libdrm' 'pybind11' 'python' 'libx11' 'wayland-protocols')
provides=('onevpl')
conflicts=('onevpl')
options=('!emptydirs')
@@ -25,6 +25,7 @@ build() {
cmake -B build -S oneVPL \
-DCMAKE_BUILD_TYPE:STRING='None' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
+ -DCMAKE_INSTALL_SYSCONFDIR:PATH='/etc' \
-DBUILD_PYTHON_BINDING:BOOL='ON' \
-DBUILD_EXAMPLES:BOOL='OFF' \
-DINSTALL_EXAMPLE_CODE:BOOL='OFF' \
@@ -35,7 +36,7 @@ build() {
package() {
make -C build DESTDIR="$pkgdir" install
install -d -m755 "${pkgdir}/usr/share/licenses"
- mv "${pkgdir}/usr/share/doc/oneVPL" "${pkgdir}/usr/share/licenses/${pkgname}"
+ mv "${pkgdir}/usr/share/vpl/licensing" "${pkgdir}/usr/share/licenses/${pkgname}"
local _pyver
_pyver="$(python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')"