summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-06-05 15:47:25 -0300
committerDaniel Bermond2022-06-05 15:47:25 -0300
commite3bc6b3ad710431e3de7034b28e4aad0c6519ca3 (patch)
tree48f2bdded4be90d16ab1d089349dc7d60ddd3167
parent6ee0a52362ee9a3eb658e40e552ebde818633496 (diff)
downloadaur-e3bc6b3ad710431e3de7034b28e4aad0c6519ca3.tar.gz
Add tests. Update url and dependencies. Add install paths in cmake.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD26
2 files changed, 20 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03b9550e3477..28a2fb616bed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,23 @@
pkgbase = onevpl-git
pkgdesc = oneAPI Video Processing Library (git version)
pkgver = 2022.1.4.r0.g8f6d55d
- pkgrel = 2
- url = https://software.intel.com/content/www/us/en/develop/tools/oneapi/components/onevpl.html
+ pkgrel = 3
+ url = https://www.intel.com/content/www/us/en/developer/tools/oneapi/onevpl.html
arch = x86_64
license = MIT
makedepends = git
makedepends = cmake
- makedepends = libdrm
+ makedepends = libx11
makedepends = pybind11
makedepends = python
- makedepends = libx11
makedepends = wayland-protocols
+ depends = libdrm
depends = libva
+ depends = wayland
optdepends = onevpl-runtime: for runtime implementation
optdepends = python: for python bindings
provides = onevpl
conflicts = onevpl
- options = !emptydirs
source = git+https://github.com/oneapi-src/oneVPL.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d1c472a01265..5e44c6286c10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,17 @@
pkgname=onevpl-git
pkgver=2022.1.4.r0.g8f6d55d
-pkgrel=2
+pkgrel=3
pkgdesc='oneAPI Video Processing Library (git version)'
arch=('x86_64')
-url='https://software.intel.com/content/www/us/en/develop/tools/oneapi/components/onevpl.html'
+url='https://www.intel.com/content/www/us/en/developer/tools/oneapi/onevpl.html'
license=('MIT')
-depends=('libva')
+depends=('libdrm' 'libva' 'wayland')
optdepends=('onevpl-runtime: for runtime implementation'
'python: for python bindings')
-makedepends=('git' 'cmake' 'libdrm' 'pybind11' 'python' 'libx11' 'wayland-protocols')
+makedepends=('git' 'cmake' 'libx11' 'pybind11' 'python' 'wayland-protocols')
provides=('onevpl')
conflicts=('onevpl')
-options=('!emptydirs')
source=('git+https://github.com/oneapi-src/oneVPL.git')
sha256sums=('SKIP')
@@ -22,25 +21,30 @@ pkgver() {
}
build() {
+ local _pyver
+ _pyver="$(python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')"
+
cmake -B build -S oneVPL \
-DCMAKE_BUILD_TYPE:STRING='None' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
-DCMAKE_INSTALL_SYSCONFDIR:PATH='/etc' \
-DBUILD_PYTHON_BINDING:BOOL='ON' \
-DBUILD_EXAMPLES:BOOL='OFF' \
+ -DBUILD_TESTS:BOOL='ON' \
-DINSTALL_EXAMPLE_CODE:BOOL='OFF' \
+ -DONEAPI_INSTALL_LICENSEDIR:STRING="share/licenses/${pkgname}" \
+ -DONEAPI_INSTALL_PYTHONDIR:STRING="lib/python${_pyver}" \
+ -DPYTHON_INSTALL_DIR:STRING="lib/python${_pyver}" \
-Wno-dev
make -C build
}
+check() {
+ make -C build test
+}
+
package() {
make -C build DESTDIR="$pkgdir" install
- install -d -m755 "${pkgdir}/usr/share/licenses"
- mv "${pkgdir}/usr/share/vpl/licensing" "${pkgdir}/usr/share/licenses/${pkgname}"
-
- local _pyver
- _pyver="$(python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')"
- mv "${pkgdir}/usr/lib/python"{,"$_pyver"}
local _file
while read -r -d '' _file