summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2021-07-09 22:08:22 +0000
committerDaniel Bermond2021-07-09 22:08:22 +0000
commitf87e40295970d8a7dc753883ee5b3d7e72257d6c (patch)
tree4670f42c01a48c10371fbff7630e6480af73287b
downloadaur-f87e40295970d8a7dc753883ee5b3d7e72257d6c.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD41
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6968d3cbfd4d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = onevpl-git
+ pkgdesc = oneAPI Video Processing Library (git version)
+ pkgver = 2021.4.0.r0.gd5c0725
+ pkgrel = 1
+ url = https://software.intel.com/content/www/us/en/develop/tools/oneapi/components/onevpl.html
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ makedepends = libdrm
+ makedepends = pybind11
+ makedepends = python
+ makedepends = libx11
+ depends = libva
+ optdepends = onevpl-runtime: for runtime implementation
+ optdepends = python: for python bindings
+ provides = onevpl
+ conflicts = onevpl
+ options = !emptydirs
+ source = git+https://github.com/oneapi-src/oneVPL.git
+ sha256sums = SKIP
+
+pkgname = onevpl-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b07ce804d604
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Daniel Bermond <dbermond@archlinux.org>
+
+pkgname=onevpl-git
+pkgver=2021.4.0.r0.gd5c0725
+pkgrel=1
+pkgdesc='oneAPI Video Processing Library (git version)'
+arch=('x86_64')
+url='https://software.intel.com/content/www/us/en/develop/tools/oneapi/components/onevpl.html'
+license=('MIT')
+depends=('libva')
+optdepends=('onevpl-runtime: for runtime implementation'
+ 'python: for python bindings')
+makedepends=('git' 'cmake' 'libdrm' 'pybind11' 'python' 'libx11')
+provides=('onevpl')
+conflicts=('onevpl')
+options=('!emptydirs')
+source=('git+https://github.com/oneapi-src/oneVPL.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ git -C oneVPL describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+}
+
+build() {
+ cmake -B build -S oneVPL \
+ -DCMAKE_BUILD_TYPE:STRING='None' \
+ -DCMAKE_INSTALL_PREFIX:PATH='/usr' \
+ -DBUILD_PYTHON_BINDING:BOOL='ON' \
+ -Wno-dev
+ make -C build
+}
+
+package() {
+ make -C build DESTDIR="$pkgdir" install
+ install -d -m755 "${pkgdir}/usr/share/licenses"
+ mv "${pkgdir}/usr/share/doc/oneVPL" "${pkgdir}/usr/share/licenses/${pkgname}"
+
+ local _pyver
+ _pyver="$(python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')"
+ mv "${pkgdir}/usr/lib/python"{,"$_pyver"}
+}