summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2023-03-07 15:18:42 -0300
committerDaniel Bermond2023-03-07 15:18:42 -0300
commitfb7808be341121afa77046f63cc76f0435d38d68 (patch)
treec4bd0d823a0c1f162e0b5b16ef645a36cffafa95
parent80ed8acee066efa44acfe6d3ce4e58ad731d3eef (diff)
downloadaur-fb7808be341121afa77046f63cc76f0435d38d68.tar.gz
Match latest upstream changes
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD20
2 files changed, 9 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d85caa97634c..5374bbf31e51 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = onevpl-git
pkgdesc = oneAPI Video Processing Library (git version)
- pkgver = 2023.1.1.r0.g5d7b6af
+ pkgver = 2023.1.3.r0.g4cdf44c
pkgrel = 1
url = https://www.intel.com/content/www/us/en/developer/tools/oneapi/onevpl.html
arch = x86_64
@@ -8,14 +8,11 @@ pkgbase = onevpl-git
makedepends = git
makedepends = cmake
makedepends = libx11
- makedepends = pybind11
- makedepends = python
makedepends = wayland-protocols
depends = libdrm
depends = libva
depends = wayland
optdepends = onevpl-runtime: for runtime implementation
- optdepends = python: for python bindings
provides = onevpl
conflicts = onevpl
source = git+https://github.com/oneapi-src/oneVPL.git
diff --git a/PKGBUILD b/PKGBUILD
index 93c0f61b64ad..3e667ddf1d10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,15 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=onevpl-git
-pkgver=2023.1.1.r0.g5d7b6af
+pkgver=2023.1.3.r0.g4cdf44c
pkgrel=1
pkgdesc='oneAPI Video Processing Library (git version)'
arch=('x86_64')
url='https://www.intel.com/content/www/us/en/developer/tools/oneapi/onevpl.html'
license=('MIT')
depends=('libdrm' 'libva' 'wayland')
-optdepends=('onevpl-runtime: for runtime implementation'
- 'python: for python bindings')
-makedepends=('git' 'cmake' 'libx11' 'pybind11' 'python' 'wayland-protocols')
+optdepends=('onevpl-runtime: for runtime implementation')
+makedepends=('git' 'cmake' 'libx11' 'wayland-protocols')
provides=('onevpl')
conflicts=('onevpl')
source=('git+https://github.com/oneapi-src/oneVPL.git')
@@ -21,10 +20,8 @@ pkgver() {
}
build() {
- local _pyver
- _pyver="$(python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')"
-
cmake -B build -S oneVPL \
+ -G 'Unix Makefiles' \
-DCMAKE_BUILD_TYPE:STRING='None' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
-DCMAKE_INSTALL_SYSCONFDIR:PATH='/etc' \
@@ -32,22 +29,21 @@ build() {
-DBUILD_TESTS:BOOL='ON' \
-DINSTALL_EXAMPLE_CODE:BOOL='OFF' \
-DONEAPI_INSTALL_LICENSEDIR:STRING="share/licenses/${pkgname}" \
- -DONEAPI_INSTALL_PYTHONDIR:STRING="lib/python${_pyver}" \
-Wno-dev
- make -C build
+ cmake --build build
}
check() {
- make -C build test
+ ctest --test-dir build --output-on-failure
}
package() {
- make -C build DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
local _file
while read -r -d '' _file
do
- if ! grep -q '^vpl\-' <<< "$_file"
+ if ! grep -q '^vpl-' <<< "$_file"
then
mv "${pkgdir}/usr/bin"/{,vpl-}"$_file"
fi