summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmadeus Folego2019-01-18 13:04:45 -0200
committerAmadeus Folego2019-01-18 13:04:45 -0200
commitf6db23ae88882b760c94ae50e89286ac5d36a3cb (patch)
treece2c4aba7d8abee8aabf77211a52fe148225844d
parentfd1ba0c68de0d99bc371d12cf50979f0e68c64ee (diff)
downloadaur-f6db23ae88882b760c94ae50e89286ac5d36a3cb.tar.gz
Workaround issue with neovim > 0.3.1
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cd01c62405e0..04cdf17797fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc='An IDE built around Neovim'
arch=(x86_64)
url="https://github.com/onivim/oni"
license=('MIT')
-depends=('neovim<=0.3.1' 'nodejs' 'gconf' 'libxss')
+depends=('neovim' 'nodejs' 'gconf' 'libxss')
makedepends=('tar')
source=("https://github.com/onivim/${pkgname}/releases/download/v${pkgver}/Oni-${pkgver}-x64-linux.tar.gz"
"oni.sh"
@@ -19,8 +19,13 @@ sha256sums=('417dad56e06dc42edbae21591da06f381769c5efd042ac89784f90e7f90fe9ea'
'9b09686c82ac5670ece59608288ab2124ee3147d404b77ac58c6ba332a6a148a')
package() {
+ # See: https://github.com/onivim/oni/issues/2704
install -d ${pkgdir}/opt/${pkgname}
+
cp -R ${srcdir}/Oni-${pkgver}-x64-linux/* ${pkgdir}/opt/${pkgname}
+
+ sed -i -e 's/--embed/--embed","--headless/g' ${pkgdir}/opt/${pkgname}/resources/app/lib/browser/vendor.bundle.js
+
install -Dm755 $srcdir/${pkgname}.sh ${pkgdir}/usr/bin/${pkgname}
install -Dm644 oni.desktop "$pkgdir/usr/share/applications/oni.desktop"