summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrevel2022-08-23 06:06:07 +0200
committerrevel2022-08-23 06:06:07 +0200
commit34599d34a106e763daa3cad3673ff8ed6ae5fd16 (patch)
tree1a6df91554483d292c31d2e3dc472d53d636fc24
parent843ec2dda389ff6573fb7bebddc6fa7108b3e2fc (diff)
downloadaur-34599d34a106e763daa3cad3673ff8ed6ae5fd16.tar.gz
- updated to 0.4.7
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD13
2 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e273ab3ca30..3c7243634846 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = onioncat
pkgdesc = OnionCat is a VPN-adapter, which uses Tor or I2P as its transport.
- pkgver = 0.3.9
+ pkgver = 0.4.7
pkgrel = 1
url = https://www.onioncat.org/
arch = i686
@@ -8,11 +8,14 @@ pkgbase = onioncat
license = GPL3
depends = tor
depends = net-tools
- source = https://www.cypherpunk.at/ocat/download/Source/current/onioncat-0.3.9.tar.gz
- source = https://www.cypherpunk.at/ocat/download/Source/current/onioncat-0.3.9.tar.gz.asc
+ source = https://www.cypherpunk.at/ocat/download/Source/current/onioncat-0.4.7.tar.gz
+ source = https://www.cypherpunk.at/ocat/download/Source/current/onioncat-0.4.7.tar.gz.asc
+ source = https://www.cypherpunk.at/ocat/download/Source/current/onioncat-0.4.7.tar.gz.sha256
+ source = https://www.cypherpunk.at/ocat/download/Source/current/onioncat-0.4.7.tar.gz.sig
validpgpkeys = 98678E06063007E4A1F0B9C59BD601668E24F29D
- sha512sums = 0b036e4de92877c5e15288a736217bec6e59fccebe6e13063200b13e7d0e80dcfa38ccf36cf9507cbdba9c700d47171a1a65ba96fffd25de6fe23bea980d7a15
+ sha512sums = b76da22051907e99f9a6ae6e089d5eb83502b6e3deb096ef00e4d2ed02da1c09b0aba1ad00c85e45622f92c94ba866930840b51b5859d775229606f40b463c59
+ sha512sums = SKIP
+ sha512sums = SKIP
sha512sums = SKIP
pkgname = onioncat
-
diff --git a/PKGBUILD b/PKGBUILD
index 0e3ed5fbe2ca..2447b10092ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,29 @@
# Contributor: jwwolf <jwwolf+arch@gmail.com>
pkgname=onioncat
-pkgver=0.3.9
+pkgver=0.4.7
pkgrel=1
pkgdesc='OnionCat is a VPN-adapter, which uses Tor or I2P as its transport.'
arch=('i686' 'x86_64')
url='https://www.onioncat.org/'
license=('GPL3')
depends=('tor' 'net-tools')
-source=("https://www.cypherpunk.at/ocat/download/Source/current/${pkgname}-${pkgver}.tar.gz"{,.asc})
+source=("https://www.cypherpunk.at/ocat/download/Source/current/${pkgname}-${pkgver}.tar.gz"{,.asc,.sha256,.sig})
validpgpkeys=('98678E06063007E4A1F0B9C59BD601668E24F29D') # Bernhard R. Fischer (Eagle) <bf@abenteuerland.at>
-sha512sums=('0b036e4de92877c5e15288a736217bec6e59fccebe6e13063200b13e7d0e80dcfa38ccf36cf9507cbdba9c700d47171a1a65ba96fffd25de6fe23bea980d7a15'
+sha512sums=('b76da22051907e99f9a6ae6e089d5eb83502b6e3deb096ef00e4d2ed02da1c09b0aba1ad00c85e45622f92c94ba866930840b51b5859d775229606f40b463c59'
+ 'SKIP'
+ 'SKIP'
'SKIP')
build() {
cd "${pkgname}-${pkgver}"
- ./configure --prefix=/usr
+ ./configure --prefix=/usr --localstatedir=/var/lib --runstatedir=/run --sysconfdir=/etc
make
}
package() {
cd "${pkgname}-${pkgver}"
- make DESTDIR="$pkgdir/" install
+# make DESTDIR="$pkgdir" prefix="$pkgdir" install
+ make prefix="$pkgdir/usr" exec_prefix="$pkgdir/usr" localstatedir="$pkgdir/var/lib" install
}