summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Fracker, Jr2018-11-05 03:36:25 -0600
committerMartin Fracker, Jr2018-11-05 03:36:25 -0600
commit3f9d233e58bcb15f0078d231492efab5e5bc3e03 (patch)
treea55189a064ef4b22bcc24c161541f5be2d2273fd
downloadaur-3f9d233e58bcb15f0078d231492efab5e5bc3e03.tar.gz
Initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD48
-rw-r--r--icons.tar.gzbin0 -> 206163 bytes
-rw-r--r--oni.desktop13
5 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed8eb840f812
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = onivim-git
+ pkgdesc = Modern modal editing, powered by Neovim
+ pkgver = v0.3.7.beta2.r28.gc64f92926
+ pkgrel = 1
+ url = https://github.com/onivim/oni
+ arch = x86_64
+ license = MIT
+ makedepends = tar
+ makedepends = rsync
+ depends = neovim
+ depends = nodejs-lts-carbon
+ depends = gconf
+ depends = libxss
+ provides = oni
+ conflicts = oni
+ source = onivim-git::git+https://github.com/onivim/oni.git
+ source = LICENSE::https://raw.githubusercontent.com/onivim/oni/master/LICENSE
+ source = oni.desktop
+ source = icons.tar.gz
+ sha256sums = SKIP
+ sha256sums = a446f219aabe3667850444bbd5f11b7e931889b4d5dbf3bc074fe00f25f1124c
+ sha256sums = ca73ce42a92eb87f2a65fb37db6dd84b428c1492fb7f1c7c831cda3deca72295
+ sha256sums = 9b09686c82ac5670ece59608288ab2124ee3147d404b77ac58c6ba332a6a148a
+
+pkgname = onivim-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4eb9bb0f5ca7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+onivim-*.tar.xz
+
+LICENSE
+icons/
+pkg/
+src/
+onivim-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d74154ee49bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Martin Fracker, Jr. <martin.frackerjr@gmail.com>
+
+pkgname=onivim-git
+pkgver=v0.3.7.beta2.r28.gc64f92926
+pkgrel=1
+pkgdesc="Modern modal editing, powered by Neovim"
+arch=(x86_64)
+conflicts=("oni")
+provides=("oni")
+url="https://github.com/onivim/oni"
+license=("MIT")
+depends=("neovim" "nodejs-lts-carbon" "gconf" "libxss")
+makedepends=("tar" "rsync")
+source=("$pkgname::git+https://github.com/onivim/oni.git"
+ "LICENSE::https://raw.githubusercontent.com/onivim/oni/master/LICENSE"
+ "oni.desktop"
+ "icons.tar.gz")
+sha256sums=("SKIP"
+ "a446f219aabe3667850444bbd5f11b7e931889b4d5dbf3bc074fe00f25f1124c"
+ "ca73ce42a92eb87f2a65fb37db6dd84b428c1492fb7f1c7c831cda3deca72295"
+ "9b09686c82ac5670ece59608288ab2124ee3147d404b77ac58c6ba332a6a148a")
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed "s/\([^-]*-g\)/r\1/;s/-/./g"
+}
+
+package() {
+ install -dm755 "$pkgdir/opt/$pkgname"
+ install -dm755 "$pkgdir/usr/bin"
+
+ dir="$srcdir/$pkgname"
+
+ yarn --cwd $dir install || echo "If you are using nvm, run 'nvm use system'"
+ yarn --cwd $dir run build
+ yarn --cwd $dir run pack --dir
+
+ rsync -r "$dir/dist/linux-unpacked/" "$pkgdir/opt/$pkgname"
+ install -Dm644 oni.desktop $pkgdir/usr/share/applications/oni.desktop
+
+ ln -s /opt/$pkgname/oni $pkgdir/usr/bin/oni
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ for i in 16x16 32x32 64x64 128x128 256x256 512x512 1024x1024; do
+ install -Dm644 icons/$i.png $pkgdir/usr/share/icons/hicolor/$i/apps/oni.png
+ done
+}
+# vim:set ts=2 sw=2 et:
diff --git a/icons.tar.gz b/icons.tar.gz
new file mode 100644
index 000000000000..11a93f6d20c6
--- /dev/null
+++ b/icons.tar.gz
Binary files differ
diff --git a/oni.desktop b/oni.desktop
new file mode 100644
index 000000000000..6ddcb6b54573
--- /dev/null
+++ b/oni.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Name=Oni
+GenericName=Text Editor
+Comment=An IDE powered by Neovim
+Exec=oni %F
+TryExec=oni
+Terminal=false
+Type=Application
+MimeType=text/english;text/plain;text/markdown;text/x-makefile;text/x-c++hdr;text/x-c++src;text/x-chdr;text/x-csrc;text/x-java;text/x-moc;text/x-pascal;text/x-tcl;text/x-tex;application/x-shellscript;text/x-c;text/x-c++;text/x-ruby;text/x-python;
+Icon=oni
+Categories=Utility;TextEditor;
+Keywords=Text;Editor;Neovim
+StartupNotify=false \ No newline at end of file