summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorprimetoxinz2019-03-29 20:43:43 -0400
committerprimetoxinz2019-03-29 20:43:43 -0400
commita5757f138e77f73dcc8ea75755b5d7afd995d00b (patch)
treeab8d554c2f2928c7098a3c7d9f6064a829deb4cf
downloadaur-a5757f138e77f73dcc8ea75755b5d7afd995d00b.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--49-onlykey.rules22
-rw-r--r--PKGBUILD24
4 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6fa7ab5eee6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = onlykey
+ pkgdesc = OnlyKey Chrome Desktop App
+ pkgver = 5.0.0
+ pkgrel = 1
+ url = https://onlykey.io/
+ arch = x86_64
+ license = custom
+ source = https://s3.amazonaws.com/onlykey/apps/desktop/releases/latest/OnlyKey_5.0.0.deb.gz
+ source = https://raw.githubusercontent.com/trustcrypto/trustcrypto.github.io/master/49-onlykey.rules
+ sha256sums = 517d8d795b4a293b773676623997464b91e7756f1e2454b5e6c3c692fd467ed3
+ sha256sums = 23f3d18e8c5cd02823954f0065956b69e07bbdfeac95a04589beb33a154526c0
+
+pkgname = onlykey
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..be54450158c5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.gz
+*.deb
diff --git a/49-onlykey.rules b/49-onlykey.rules
new file mode 100644
index 000000000000..4421d7b851a7
--- /dev/null
+++ b/49-onlykey.rules
@@ -0,0 +1,22 @@
+# UDEV Rules for OnlyKey, https://docs.crp.to/linux.html
+#
+# This file must be placed at:
+#
+# /etc/udev/rules.d/49-onlykey.rules (preferred location)
+# or
+# /lib/udev/rules.d/49-onlykey.rules (req'd on some broken systems)
+#
+# To install, type this command in a terminal:
+# sudo cp 49-onlykey.rules /etc/udev/rules.d/49-onlykey.rules
+#
+# After this file is installed, physically unplug and reconnect OnlyKey.
+#
+ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789B]?", ENV{ID_MM_DEVICE_IGNORE}="1"
+ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789A]?", ENV{MTP_NO_PROBE}="1"
+SUBSYSTEMS=="usb", ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789ABCD]?", MODE:="0666"
+KERNEL=="ttyACM*", ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789B]?", MODE:="0666"
+#
+# If you share your linux system with other users, or just don't like the
+# idea of write permission for everybody, you can replace MODE:="0666" with
+# OWNER:="yourusername" to create the device owned by you, or with
+# GROUP:="somegroupname" and mange access using standard unix groups.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9be4efa9a09f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: primetoxinz
+
+pkgname=onlykey
+pkgver=5.0.0
+pkgrel=1
+pkgdesc="OnlyKey Chrome Desktop App"
+arch=('x86_64')
+url="https://onlykey.io/"
+license=('custom')
+#depends=('')
+source=("https://s3.amazonaws.com/onlykey/apps/desktop/releases/latest/OnlyKey_${pkgver}.deb.gz"
+"https://raw.githubusercontent.com/trustcrypto/trustcrypto.github.io/master/49-onlykey.rules")
+sha256sums=('517d8d795b4a293b773676623997464b91e7756f1e2454b5e6c3c692fd467ed3'
+'23f3d18e8c5cd02823954f0065956b69e07bbdfeac95a04589beb33a154526c0')
+
+
+package() {
+ bsdtar -O -xf "OnlyKey_${pkgver}"*.deb.gz data.tar.xz | bsdtar -C "${pkgdir}" -xJf -
+
+ find "${pkgdir}" -type d -exec chmod 755 {} +
+ chmod 755 "${pkgdir}"/usr/share/applications/OnlyKey.desktop
+
+ install -Dm 644 49-onlykey.rules "${pkgdir}/usr/lib/udev/rules.d/49-onlykey.rules"
+}