summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Haag2022-09-19 14:26:25 +0200
committerChristoph Haag2022-09-19 14:26:25 +0200
commitd03e8cedc932cae144973165a8f97cc21f059613 (patch)
tree896cd10b7cc6bcc4b5f35db7520867b9b06728d8
parent223e809244bf01762df40b9df7d5a68a3cbe67c2 (diff)
downloadaur-d03e8cedc932cae144973165a8f97cc21f059613.tar.gz
update
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f69aaeec7c49..a8e9b037d654 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = onnxruntime-git
pkgdesc = cross-platform inference and training machine-learning accelerator.
- pkgver = orttraining_rc2.r3930.g3d99f16e98
+ pkgver = orttraining_rc2.r4438.g14365b67a0
pkgrel = 1
url = https://onnxruntime.ai/
arch = x86_64
@@ -9,9 +9,10 @@ pkgbase = onnxruntime-git
makedepends = cmake
makedepends = ninja
depends = gcc-libs
+ depends = python
provides = onnxruntime
conflicts = onnxruntime
- source = git+https://github.com/microsoft/onnxruntime.git
+ source = git+https://github.com/microsoft/onnxruntime.git#branch=main
md5sums = SKIP
pkgname = onnxruntime-git
diff --git a/PKGBUILD b/PKGBUILD
index e31f4fbcb374..e95089253370 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
_pkgname=onnxruntime
pkgname=onnxruntime-git
-pkgver=orttraining_rc2.r3930.g3d99f16e98
+pkgver=orttraining_rc2.r4438.g14365b67a0
pkgrel=1
pkgdesc="cross-platform inference and training machine-learning accelerator."
arch=('x86_64')
url="https://onnxruntime.ai/"
license=('MIT')
-depends=('gcc-libs')
+depends=('gcc-libs' 'python')
makedepends=('git' 'cmake' 'ninja')
checkdepends=()
optdepends=()
@@ -18,7 +18,7 @@ replaces=()
options=()
# install=
# changelog=
-source=("git+https://github.com/microsoft/onnxruntime.git")
+source=("git+https://github.com/microsoft/onnxruntime.git#branch=main")
md5sums=('SKIP')
prepare() {
@@ -46,6 +46,9 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-Donnxruntime_BUILD_SHARED_LIB=ON \
-DONNX_USE_PROTOBUF_SHARED_LIBS=ON \
+ -DPYTHON_INCLUDE_DIR=$(python -c "from distutils.sysconfig import get_python_inc; print(get_python_inc())") \
+ -DPYTHON_LIBRARY=$(python -c "import distutils.sysconfig as sysconfig; print(sysconfig.get_config_var('LIBDIR'))") \
+ -DPYTHON_EXECUTABLE:FILEPATH=$(which python) \
.
ninja -C $srcdir/$_pkgname-build
}