summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot2015-06-09 01:05:58 +0100
committerEmmanuel Gil Peyrot2015-06-09 01:05:58 +0100
commit138f0670e97625eb648f06ad9430df5c139e9a9e (patch)
treee3681095fc72dcf3487bead52711633820ba777a
downloadaur-138f0670e97625eb648f06ad9430df5c139e9a9e.tar.gz
Initial commit.
-rw-r--r--.SRCINFO19
-rw-r--r--Makefile7
-rw-r--r--PKGBUILD26
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de29cd8d42a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = onscripter
+ pkgdesc = A game engine compatible to NScripter, to create and perform visual novel games
+ pkgver = 20150208
+ pkgrel = 1
+ url = http://onscripter.sourceforge.jp/onscripter.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = bzip2
+ depends = sdl_image
+ depends = sdl_mixer
+ depends = sdl_ttf
+ source = http://onscripter.sourceforge.jp/onscripter-20150208.tar.gz
+ source = Makefile
+ md5sums = 5b4278c1826c2f9b91052e3238b31c8b
+ md5sums = 325952c28bf369c5c21c330fabaa86c7
+
+pkgname = onscripter
+
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..ff9bb433b03b
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,7 @@
+LIBS = `sdl-config --libs` `smpeg-config --libs` -lSDL_ttf -lSDL_image -lSDL_mixer -lbz2 -ljpeg -lm -logg -lvorbis -lvorbisfile
+CFLAGS += -c `sdl-config --cflags` `smpeg-config --cflags` -DLINUX -DUSE_OGG_VORBIS
+OBJSUFFIX = .o
+CC = g++
+LD = g++ -o
+TARGET = onscripter
+include Makefile.onscripter
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1cc23981748d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
+# Contributor: Christoph Zeiler <rabyte@gmail.com>
+
+pkgname=onscripter
+pkgver=20150208
+pkgrel=1
+pkgdesc="A game engine compatible to NScripter, to create and perform visual novel games"
+arch=('i686' 'x86_64')
+url="http://onscripter.sourceforge.jp/onscripter.html"
+license=('GPL')
+depends=('bzip2' 'sdl_image' 'sdl_mixer' 'sdl_ttf')
+source=("http://onscripter.sourceforge.jp/$pkgname-$pkgver.tar.gz"
+ 'Makefile')
+md5sums=('5b4278c1826c2f9b91052e3238b31c8b'
+ '325952c28bf369c5c21c330fabaa86c7')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ln -s "$srcdir/Makefile" .
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 onscripter "$pkgdir/usr/bin/onscripter"
+}