summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Wieczorek2016-05-14 17:18:53 +0200
committerMarcin Wieczorek2016-05-14 17:18:53 +0200
commitc0dfbb7a3f8b81c80222da446b084bf516a12ac1 (patch)
tree8e8556cfc538740a69c7600939d28161bf90b3cd
parent138f0670e97625eb648f06ad9430df5c139e9a9e (diff)
downloadaur-c0dfbb7a3f8b81c80222da446b084bf516a12ac1.tar.gz
Update to 20160407
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore2
-rw-r--r--Makefile7
-rw-r--r--PKGBUILD28
-rw-r--r--avifile.patch19
5 files changed, 43 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de29cd8d42a4..d8e4f6842b18 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = onscripter
pkgdesc = A game engine compatible to NScripter, to create and perform visual novel games
- pkgver = 20150208
+ pkgver = 20160407
pkgrel = 1
url = http://onscripter.sourceforge.jp/onscripter.html
arch = i686
@@ -10,10 +10,10 @@ pkgbase = onscripter
depends = sdl_image
depends = sdl_mixer
depends = sdl_ttf
- source = http://onscripter.sourceforge.jp/onscripter-20150208.tar.gz
- source = Makefile
- md5sums = 5b4278c1826c2f9b91052e3238b31c8b
- md5sums = 325952c28bf369c5c21c330fabaa86c7
+ source = http://onscripter.sourceforge.jp/onscripter-20160407.tar.gz
+ source = avifile.patch
+ md5sums = 29679673a332e3b3f00bdd9c579b93e2
+ md5sums = 9eec223b2bb76e8e83ef4e67de87b2ae
pkgname = onscripter
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..62d30f9218cb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+src/
+pkg/
diff --git a/Makefile b/Makefile
deleted file mode 100644
index ff9bb433b03b..000000000000
--- a/Makefile
+++ /dev/null
@@ -1,7 +0,0 @@
-LIBS = `sdl-config --libs` `smpeg-config --libs` -lSDL_ttf -lSDL_image -lSDL_mixer -lbz2 -ljpeg -lm -logg -lvorbis -lvorbisfile
-CFLAGS += -c `sdl-config --cflags` `smpeg-config --cflags` -DLINUX -DUSE_OGG_VORBIS
-OBJSUFFIX = .o
-CC = g++
-LD = g++ -o
-TARGET = onscripter
-include Makefile.onscripter
diff --git a/PKGBUILD b/PKGBUILD
index 1cc23981748d..f6e8fdb29fa4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,32 @@
-# Maintainer: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
+# Maintainer: Marcin (CTRL) Wieczorek <marcin@marcin.co>
+# Contributor: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
# Contributor: Christoph Zeiler <rabyte@gmail.com>
pkgname=onscripter
-pkgver=20150208
+pkgver=20160407
pkgrel=1
pkgdesc="A game engine compatible to NScripter, to create and perform visual novel games"
arch=('i686' 'x86_64')
url="http://onscripter.sourceforge.jp/onscripter.html"
license=('GPL')
depends=('bzip2' 'sdl_image' 'sdl_mixer' 'sdl_ttf')
-source=("http://onscripter.sourceforge.jp/$pkgname-$pkgver.tar.gz"
- 'Makefile')
-md5sums=('5b4278c1826c2f9b91052e3238b31c8b'
- '325952c28bf369c5c21c330fabaa86c7')
+source=("http://onscripter.sourceforge.jp/${pkgname}-${pkgver}.tar.gz"
+ 'avifile.patch')
+
+md5sums=('29679673a332e3b3f00bdd9c579b93e2'
+ '9eec223b2bb76e8e83ef4e67de87b2ae')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p1 -i ${srcdir}/avifile.patch
+}
build() {
- cd "$pkgname-$pkgver"
- ln -s "$srcdir/Makefile" .
- make
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make -f Makefile.Linux
}
package() {
- cd "$pkgname-$pkgver"
- install -Dm755 onscripter "$pkgdir/usr/bin/onscripter"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -Dm755 onscripter "${pkgdir}/usr/bin/onscripter"
}
diff --git a/avifile.patch b/avifile.patch
new file mode 100644
index 000000000000..5ecf32fd1a6f
--- /dev/null
+++ b/avifile.patch
@@ -0,0 +1,19 @@
+--- a/Makefile.Linux 2016-04-07 19:39:17.000000000 +0200
++++ b/Makefile.Linux 2016-05-14 17:04:15.122758334 +0200
+@@ -42,11 +42,11 @@
+ DEFS += -DUSE_CDROM
+
+ # optional: avifile
+-DEFS += -DUSE_AVIFILE
+-INCS += `avifile-config --cflags`
+-LIBS += `avifile-config --libs`
+-TARGET += simple_aviplay$(EXESUFFIX)
+-EXT_OBJS += AVIWrapper$(OBJSUFFIX)
++# DEFS += -DUSE_AVIFILE
++# INCS += `avifile-config --cflags`
++# LIBS += `avifile-config --libs`
++# TARGET += simple_aviplay$(EXESUFFIX)
++# EXT_OBJS += AVIWrapper$(OBJSUFFIX)
+
+ # optional: lua
+ DEFS += -DUSE_LUA