summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCastor2023-06-09 08:17:05 +0545
committerCastor2023-06-09 08:17:05 +0545
commit72730f336e8f7a125f2d9a4af98cc8cc5650c6cf (patch)
treea18aaa70765a8db231f71de2dc3f35d92d80b9ee
parent14a25d40a2e57266cc6b38d0848c1d8878891fdf (diff)
downloadaur-72730f336e8f7a125f2d9a4af98cc8cc5650c6cf.tar.gz
Updated PKGBUILD to new v0.5
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD41
2 files changed, 39 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 87ffe01dcabe..d73310ff6108 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,26 @@
pkgbase = onthespot-git
- pkgdesc = A qt based free spotify downloader written in python.
- pkgver = 0.4
+ pkgdesc = Qt based music downloader written in python.
+ pkgver = 0.5
pkgrel = 1
url = https://github.com/casualsnek/onthespot
arch = any
- license = GPL2
- makedepends = git
- makedepends = python3
- makedepends = python-pip
- makedepends = bash
+ license = GPLv2
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
depends = ffmpeg
- depends = qt5-base
+ depends = python-requests
+ depends = python-pyqt5
+ depends = python-pillow
+ depends = python-show-in-file-manager
+ depends = python-certifi
+ depends = python-pyxdg
+ depends = python-librespot
+ depends = python-music-tag
provides = onthespot
- conflicts = onthespot-git
conflicts = onthespot
- options = !strip
- options = !emptydirs
- source = onthespot::git+https://github.com/casualsnek/onthespot
+ source = https://github.com/casualsnek/onthespot/archive/refs/heads/main.zip
sha256sums = SKIP
pkgname = onthespot-git
diff --git a/PKGBUILD b/PKGBUILD
index a4c32d5e9384..67fc323f245e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,36 @@
# Maintainer: Castor <whoisyoges at castorisdead dot xyz>
pkgname=onthespot-git
-_pkgname=onthespot
-pkgver=0.4
+pkgver=0.5
+_branch="main"
pkgrel=1
-pkgdesc="A qt based free spotify downloader written in python."
+pkgdesc="Qt based music downloader written in python."
arch=('any')
url="https://github.com/casualsnek/onthespot"
-license=('GPL2')
-depends=('ffmpeg' 'qt5-base')
-makedepends=('git' 'python3' 'python-pip' 'bash')
+license=('GPLv2')
+depends=('ffmpeg' 'python-requests' 'python-pyqt5' 'python-pillow' 'python-show-in-file-manager' 'python-certifi' 'python-pyxdg' 'python-librespot' 'python-music-tag')
+conflicts=('onthespot')
provides=('onthespot')
-conflicts=('onthespot-git' 'onthespot')
-options=(!strip !emptydirs)
-source=("${_pkgname}::git+${url}")
-sha256sums=('SKIP')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+optdepends=()
+source=("$url/archive/refs/heads/$_branch.zip")
+sha256sums=(SKIP)
-pkgver() {
- cd "$srcdir/$_pkgname"
- git describe --tags | sed 's/^v//;s/-/+/g'
+build() {
+ cd "onthespot-$_branch"
+ python -m build --wheel --no-isolation
}
-build() {
- cd "$srcdir/$_pkgname"
- bash build_linux.sh
+pkgver() {
+ grep "self.version = *" "$PWD/onthespot-$_branch/src/onthespot/otsconfig.py" | sed 's/self.version = //g;s/ //g'
}
package() {
- cd "${srcdir}/$_pkgname/dist"
- install -Dm755 ./onthespot_linux "${pkgdir}/usr/local/bin/onthespot"
+ cd "onthespot-$_branch"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -dm 755 "$pkgdir/usr/share/applications"
+ install -dm 755 "$pkgdir/usr/share/icons/hicolor/"{256x256,scalable}"/apps/"
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 644 "src/onthespot/resources/org.eu.casualsnek.onthespot.desktop" "$pkgdir/usr/share/applications/"
+ install -Dm 644 "src/onthespot/resources/icon.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/casual_onthespot.svg"
+ install -Dm 644 "src/onthespot/resources/icon.png" "$pkgdir/usr/share/icons/hicolor/256x256/apps/casual_onthespot.png"
}