summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2018-04-24 22:32:16 -0400
committerJean Lucas2018-04-24 22:32:16 -0400
commit9a0774797fabc668f5acf842d9ac63f36ccbd87d (patch)
treeda56cbb29cb4d87f278e371989335e46d389db86
downloadaur-9a0774797fabc668f5acf842d9ac63f36ccbd87d.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db81d1fbcbc5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Wed Apr 25 02:32:01 UTC 2018
+pkgbase = onyx
+ pkgdesc = Decentralized messaging application based on PSS
+ pkgver = 0.4.2
+ pkgrel = 1
+ url = https://mainframe.com
+ arch = any
+ license = MIT
+ makedepends = libicns
+ depends = yarn
+ source = https://github.com/MainframeHQ/onyx/archive/v0.4.2.zip
+ sha512sums = 0c169df9d0e29677dc7621b5ffeee78d9ba41243e0122d4116bec93245f04be498208752e2432779f62f3c9ff551019cb436247cc34e9ea078cea1992f72e194
+
+pkgname = onyx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..392ec448744e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Jean Lucas <jean@4ray.co>
+
+pkgname=onyx
+pkgver=0.4.2
+pkgrel=1
+pkgdesc='Decentralized messaging application based on PSS'
+arch=(any)
+url='https://mainframe.com'
+license=(MIT)
+depends=(yarn)
+makedepends=(libicns)
+source=(https://github.com/MainframeHQ/onyx/archive/v$pkgver.zip)
+sha512sums=(0c169df9d0e29677dc7621b5ffeee78d9ba41243e0122d4116bec93245f04be498208752e2432779f62f3c9ff551019cb436247cc34e9ea078cea1992f72e194)
+
+build() {
+ cd $srcdir/onyx-$pkgver
+ yarn
+ yarn build:binaries
+ yarn dist
+}
+
+package() {
+ install -Dm 755 $srcdir/onyx-$pkgver/dist/Mainframe\ Alpha.AppImage $pkgdir/usr/bin/onyx
+}