summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2018-04-26 17:32:46 -0400
committerJean Lucas2018-04-26 17:32:46 -0400
commit53b48227ceb9ae1a20a1bc02df61f73e873d2b87 (patch)
tree0bba68b6f3d233131028dc8e93717b569f920c1e
downloadaur-53b48227ceb9ae1a20a1bc02df61f73e873d2b87.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--LICENSE19
-rw-r--r--PKGBUILD21
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..caa091dda6b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Apr 26 21:32:36 UTC 2018
+pkgbase = onyx-bin
+ pkgdesc = Decentralized messaging application based on PSS (bin)
+ pkgver = 0.4.2
+ pkgrel = 2
+ url = https://mainframe.com
+ arch = x86_64
+ license = MIT
+ conflicts = onyx
+ options = !strip
+ source = https://github.com/MainframeHQ/onyx/releases/download/v0.4.2/Mainframe-0.4.2-linux-amd64.AppImage
+ source = LICENSE
+ sha512sums = accd43344eec6b267c2ba16de3b323ee80da1b84478ea6473a7d14dfc34d88e30366aa2ac592a1f26489801103ddfb7bfe52bcf46db298a93e1e8059fed7238a
+ sha512sums = 071eb3c19e5311b119429ce20a18731b48163674628abde78496f4de6756dc7404598e281cede321f75b22aae0224c3f26fb7a6d24198ea87e04ba6815985255
+
+pkgname = onyx-bin
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..b7a24718a959
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,19 @@
+Copyright 2017 ThusFresh Inc.
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of
+this software and associated documentation files (the "Software"), to deal in
+the Software without restriction, including without limitation the rights to
+use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies
+of the Software, and to permit persons to whom the Software is furnished to do
+so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11687170c334
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Jean Lucas <jean@4ray.co>
+
+pkgname=onyx-bin
+pkgver=0.4.2
+pkgrel=2
+pkgdesc='Decentralized messaging application based on PSS (bin)'
+arch=(x86_64)
+url='https://mainframe.com'
+license=(MIT)
+conflicts=(onyx)
+options=(!strip)
+source=(https://github.com/MainframeHQ/onyx/releases/download/v$pkgver/Mainframe-$pkgver-linux-amd64.AppImage
+ LICENSE)
+sha512sums=(accd43344eec6b267c2ba16de3b323ee80da1b84478ea6473a7d14dfc34d88e30366aa2ac592a1f26489801103ddfb7bfe52bcf46db298a93e1e8059fed7238a
+ 071eb3c19e5311b119429ce20a18731b48163674628abde78496f4de6756dc7404598e281cede321f75b22aae0224c3f26fb7a6d24198ea87e04ba6815985255)
+
+package() {
+ cd $srcdir
+ install -Dm 755 Mainframe-$pkgver-linux-amd64.AppImage $pkgdir/usr/bin/onyx
+ install -Dm 644 LICENSE $pkgdir/usr/share/licenses/onyx/LICENSE
+}