summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Martin2015-06-08 10:48:10 -0500
committerStephen Martin2015-06-08 10:48:10 -0500
commit1493204ce0b8b23b83e0cf3e4fde8f16fe9e89e1 (patch)
tree9773dc10707833b8abf67f8d4af20b806bdcf7d8
downloadaur-1493204ce0b8b23b83e0cf3e4fde8f16fe9e89e1.tar.gz
Updated to AUR4
-rw-r--r--.SRCINFO18
-rw-r--r--LICENSE25
-rw-r--r--PKGBUILD43
-rw-r--r--onyx.install14
-rw-r--r--onyx.svg69
5 files changed, 169 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..117dae2542d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = onyx-sem
+ pkgdesc = A graphical interface for Structural Equation Modeling
+ pkgver = 1.0.878
+ pkgrel = 4
+ url = http://onyx.brandmaier.de
+ install = onyx.install
+ arch = any
+ license = custom
+ depends = java-runtime
+ source = http://onyx.brandmaier.de/onyx-1.0-878.jar
+ source = onyx.svg
+ source = LICENSE
+ md5sums = 388fb6a5df4f30ce7c873b16cb2a220f
+ md5sums = a82f98998f19b746d4f7d7956a38c11c
+ md5sums = adc8301181bc7ba30838a0fd327a471c
+
+pkgname = onyx-sem
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..770c960de9de
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,25 @@
+Onyx License
+
+Copyright (c) 2012, Timo von Oertzen, Andreas M. Brandmaier, and Siny Tsang
+All rights reserved.
+
+Redistribution and use of Onyx in binary forms, without
+modification, are permitted provided that the following conditions are met:
+ * Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+ * Neither the names of Timo von Oertzen, Andreas M. Brandmaier, Siny Tsang
+ nor of other contributors to Onyx may be used to endorse or promote products
+ derived from Onyx without specific prior written permission.
+
+ONYX IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
+ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL THE COPRYRIGHT HOLDERS BE LIABLE FOR ANY DIRECT, INDIRECT,
+INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY
+WAY OUT OF THE USE OF ONYX, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0eb2e720d23
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Stephen Martin <hwkiller at gmail dot com>
+pkgname=onyx-sem
+_pkgname=onyx
+pkgver=1.0.878
+_pkgver="1.0-878"
+pkgrel=4
+pkgdesc="A graphical interface for Structural Equation Modeling"
+arch=('any')
+url="http://onyx.brandmaier.de"
+license=('custom')
+depends=('java-runtime')
+backup=()
+options=()
+install="onyx.install"
+source=("${url}/${_pkgname}-${_pkgver}.jar"
+ "onyx.svg"
+ "LICENSE")
+package() {
+ install -Dm755 $srcdir/${_pkgname}-${_pkgver}.jar $pkgdir/usr/share/java/${pkgname}/${_pkgname}.jar
+ mkdir $pkgdir/usr/share/applications/
+ cat > $pkgdir/usr/share/applications/${pkgname}.desktop << "EOF"
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=Onyx
+Comment=A graphical interface for Structural Equation Modeling
+Exec=/usr/bin/java -jar /usr/share/java/onyx-sem/onyx.jar
+Categories=Science;Education
+Icon=onyx
+GenericName=Latent Variable Modeling Program
+EOF
+
+ install -Dm755 $srcdir/${_pkgname}.svg $pkgdir/usr/share/icons/hicolor/scalable/apps/${_pkgname}.svg
+ install -Dm 644 $srcdir/LICENSE $pkgdir/usr/share/licenses/${pkgname}/LICENSE
+}
+md5sums=('388fb6a5df4f30ce7c873b16cb2a220f'
+ 'a82f98998f19b746d4f7d7956a38c11c'
+ 'adc8301181bc7ba30838a0fd327a471c')
diff --git a/onyx.install b/onyx.install
new file mode 100644
index 000000000000..d0fb81593b6d
--- /dev/null
+++ b/onyx.install
@@ -0,0 +1,14 @@
+post_install() {
+ # do something here
+ post_upgrade
+}
+post_upgrade() {
+ # do something here
+ [[ -x /usr/bin/xdg-icon-resource ]] && xdg-icon-resource forceupdate --theme hicolor
+ [[ -x /usr/bin/update-desktop-database ]] && update-desktop-database -q
+ [[ -x /usr/bin/gtk-update-icon-cache ]] && gtk-update-icon-cache -f /usr/share/icons/hicolor
+}
+post_remove() {
+ # do something here
+ post_upgrade
+}
diff --git a/onyx.svg b/onyx.svg
new file mode 100644
index 000000000000..89b45adb54bd
--- /dev/null
+++ b/onyx.svg
@@ -0,0 +1,69 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<!-- Created with Inkscape (http://www.inkscape.org/) -->
+
+<svg
+ xmlns:dc="http://purl.org/dc/elements/1.1/"
+ xmlns:cc="http://creativecommons.org/ns#"
+ xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
+ xmlns:svg="http://www.w3.org/2000/svg"
+ xmlns="http://www.w3.org/2000/svg"
+ xmlns:sodipodi="http://sodipodi.sourceforge.net/DTD/sodipodi-0.dtd"
+ xmlns:inkscape="http://www.inkscape.org/namespaces/inkscape"
+ width="8.0488453mm"
+ height="8.6110849mm"
+ viewBox="0 0 28.519529 30.511718"
+ id="svg2"
+ version="1.1"
+ inkscape:version="0.91 r13725"
+ sodipodi:docname="onyx.svg">
+ <defs
+ id="defs4" />
+ <sodipodi:namedview
+ id="base"
+ pagecolor="#ffffff"
+ bordercolor="#666666"
+ borderopacity="1.0"
+ inkscape:pageopacity="0.0"
+ inkscape:pageshadow="2"
+ inkscape:zoom="2.8"
+ inkscape:cx="32.54129"
+ inkscape:cy="-25.30465"
+ inkscape:document-units="px"
+ inkscape:current-layer="layer1"
+ showgrid="false"
+ fit-margin-top="0"
+ fit-margin-left="0"
+ fit-margin-right="0"
+ fit-margin-bottom="0"
+ inkscape:window-width="1600"
+ inkscape:window-height="841"
+ inkscape:window-x="0"
+ inkscape:window-y="27"
+ inkscape:window-maximized="1" />
+ <metadata
+ id="metadata7">
+ <rdf:RDF>
+ <cc:Work
+ rdf:about="">
+ <dc:format>image/svg+xml</dc:format>
+ <dc:type
+ rdf:resource="http://purl.org/dc/dcmitype/StillImage" />
+ <dc:title />
+ </cc:Work>
+ </rdf:RDF>
+ </metadata>
+ <g
+ inkscape:label="Layer 1"
+ inkscape:groupmode="layer"
+ id="layer1"
+ transform="translate(-41.023437,-310.79184)">
+ <g
+ style="font-style:normal;font-weight:normal;font-size:40px;line-height:125%;font-family:sans-serif;letter-spacing:0px;word-spacing:0px;fill:#000000;fill-opacity:1;stroke:#ffffff;stroke-width:1px;stroke-linecap:butt;stroke-linejoin:miter;stroke-opacity:1"
+ id="flowRoot3336">
+ <path
+ d="m 69.042969,337.327 0,3.47656 -11.71875,0 0,-3.47656 q 3.457031,-1.89453 5.390625,-5.13672 1.933593,-3.24219 1.933593,-7.1875 0,-4.6875 -2.578125,-7.51953 -2.578125,-2.83203 -6.796875,-2.83203 -4.21875,0 -6.816406,2.85156 -2.578125,2.83203 -2.578125,7.5 0,3.94531 1.933594,7.1875 1.953125,3.24219 5.429687,5.13672 l 0,3.47656 -11.71875,0 0,-3.47656 6.230469,0 q -3.085937,-2.71485 -4.511719,-5.625 -1.40625,-2.91016 -1.40625,-6.50391 0,-6.21094 3.75,-10.05859 3.730469,-3.84766 9.6875,-3.84766 5.917969,0 9.6875,3.84766 3.75,3.82812 3.75,9.86328 0,3.78906 -1.386718,6.67969 -1.386719,2.89062 -4.53125,5.64453 l 6.25,0 z"
+ style=""
+ id="path4165" />
+ </g>
+ </g>
+</svg>