summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2018-02-06 22:19:46 -0500
committerSolomon Choina2018-02-06 22:19:46 -0500
commitffb920b4feb3ae63c985431c3d33b4aa19ea7914 (patch)
tree86cd354b95a736fa0ff67c42b44a4b8ba0809a78
downloadaur-ffb920b4feb3ae63c985431c3d33b4aa19ea7914.tar.gz
initial commit
-rw-r--r--.SRCINFO41
-rwxr-xr-xPKGBUILD46
-rwxr-xr-xinstall14
3 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e19338f1a590
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,41 @@
+# Generated by mksrcinfo v8
+# Wed Feb 7 03:19:35 UTC 2018
+pkgbase = onyx-suite
+ pkgdesc = Everyday usable dark theme mainly made for Xfce, IceWM or Openbox.
+ pkgver = 1.02
+ pkgrel = 1
+ url = https://github.com/sixsixfive/0nyX
+ install = install
+ arch = any
+ license = CCPL:cc-by-sa-4.0
+ makedepends = git
+ makedepends = coreutils
+ depends = sed
+ optdepends = qt5ct
+ optdepends = qt5-svg
+ optdepends = qt5-styleplugins
+ optdepends = xcursor-vanilla-dmz
+ optdepends = gtk3-nocsd
+ optdepends = xfwm4
+ optdepends = marco
+ optdepends = icewm
+ optdepends = openbox
+ optdepends = xfce4-notifyd
+ optdepends = xfdashboard
+ optdepends = plank
+ optdepends = slim
+ optdepends = onboard
+ optdepends = audacious
+ optdepends = qmmp
+ optdepends = albert
+ optdepends = gtk2
+ optdepends = gtk3>=3.20
+ optdepends = gtk-engines
+ provides = onyx-suite=1.02
+ conflicts = onyx-suite
+ conflicts = kde-gtk-config
+ source = https://raw.githubusercontent.com/sixsixfive/0nyX/master/debian/0nyx-theme-current.deb
+ sha256sums = SKIP
+
+pkgname = onyx-suite
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..15a9d4dc567e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+## PKGBUILD
+# https://github.com/sixsixfive/0nyX/tree/master/%40extra/PKGS/PKGBUILD
+pkgname=onyx-suite
+pkgver=1.02
+pkgrel=1
+pkgdesc='Everyday usable dark theme mainly made for Xfce, IceWM or Openbox.'
+arch=('any')
+url='https://github.com/sixsixfive/0nyX'
+depends=('sed')
+makedepends=('git' 'coreutils')
+optdepends=('qt5ct'
+ 'qt5-svg'
+ 'qt5-styleplugins'
+ 'xcursor-vanilla-dmz'
+ 'gtk3-nocsd'
+ 'xfwm4'
+ 'marco'
+ 'icewm'
+ 'openbox'
+ 'xfce4-notifyd'
+ 'xfdashboard'
+ 'plank'
+ 'slim'
+ 'onboard'
+ 'audacious'
+ 'qmmp'
+ 'albert'
+ 'gtk2'
+ 'gtk3>=3.20'
+ 'gtk-engines')
+install="install"
+provides=("${pkgname}=$pkgver")
+#kde gtk config breaks gtks font settings!
+conflicts=("${pkgname}" "kde-gtk-config")
+license=(CCPL:cc-by-sa-4.0)
+source=("https://raw.githubusercontent.com/sixsixfive/0nyX/master/debian/0nyx-theme-current.deb")
+sha256sums=('SKIP')
+
+package() {
+ _tmpdir=$pkgdir
+ cd $srcdir
+ tar xJf data.tar.xz
+
+ cp -r usr/ $pkgdir/
+ chmod -R 755 ${_tmpdir}
+}
diff --git a/install b/install
new file mode 100755
index 000000000000..a811bac80728
--- /dev/null
+++ b/install
@@ -0,0 +1,14 @@
+#!/bin/sh
+
+post_install() {
+ sed -i '/^#0nyX$/,+1 d' /etc/environment
+ printf '\n#0nyX\nGTK_OVERLAY_SCROLLING=0\n#0nyX\nLIBOVERLAY_SCROLLBAR=0'>> /etc/environment
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ sed -i '/^#0nyX$/,+1 d' /etc/environment
+} \ No newline at end of file