summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorc6parmak2015-07-19 14:07:34 +0300
committerc6parmak2015-07-19 14:07:34 +0300
commit761dc0de32b816034410fb917eeca453f0b18f7c (patch)
tree5d3b427cb06aae411ef60c3844ba6963147f83c5
downloadaur-761dc0de32b816034410fb917eeca453f0b18f7c.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--LICENSE5
-rwxr-xr-xPKGBUILD24
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9427671a9824
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = oof2
+ pkgdesc = Finite element analysis of microstructures.
+ pkgver = 2.1.11
+ pkgrel = 2
+ url = http://www.ctcms.nist.gov/oof/oof2/index.html
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = python2
+ depends = pygtk
+ depends = libgnomecanvas
+ depends = imagemagick
+ depends = lapack
+ source = http://www.ctcms.nist.gov/oof/oof2/source/oof2-2.1.11.tar.gz
+ source = LICENSE
+ md5sums = a1061fc08dbed4a2c15d2c569849f858
+ md5sums = c1d808bd883c2e0a30b687e3fcec4847
+
+pkgname = oof2
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..caa1f536df48
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,5 @@
+The research software provided on this web site (“software”) is provided by NIST as a public service. You may use, copy and distribute copies of the software in any medium, provided that you keep intact this entire notice. You may improve, modify and create derivative works of the software or any portion of the software, and you may copy and distribute such modifications or works. Modified works should carry a notice stating that you changed the software and should note the date and nature of any such change. Please explicitly acknowledge the National Institute of Standards and Technology as the source of the software. To facilitate maintenance we ask that before distributing modified versions of this software, you first contact the authors at oof_manager@nist.gov.
+
+The software is expressly provided “AS IS.” NIST MAKES NO WARRANTY OF ANY KIND, EXPRESS, IMPLIED, IN FACT OR ARISING BY OPERATION OF LAW, INCLUDING, WITHOUT LIMITATION, THE IMPLIED WARRANTY OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, NON-INFRINGEMENT AND DATA ACCURACY. NIST NEITHER REPRESENTS NOR WARRANTS THAT THE OPERATION OF THE SOFTWARE WILL BE UNINTERRUPTED OR ERROR-FREE, OR THAT ANY DEFECTS WILL BE CORRECTED. NIST DOES NOT WARRANT OR MAKE ANY REPRESENTATIONS REGARDING THE USE OF THE SOFTWARE OR THE RESULTS THEREOF, INCLUDING BUT NOT LIMITED TO THE CORRECTNESS, ACCURACY, RELIABILITY, OR USEFULNESS OF THE SOFTWARE.
+
+You are solely responsible for determining the appropriateness of using and distributing the software and you assume all risks associated with its use, including but not limited to the risks and costs of program errors, compliance with applicable laws, damage to or loss of data, programs or equipment, and the unavailability or interruption of operation. This software is not intended to be used in any situation where a failure could cause risk of injury or damage to property. The software was developed by NIST employees. NIST employee contributions are not subject to copyright protection within the United States.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..018a4fece53c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Can Altıparmak (gulaghad) <can6parmak <AT> gmail <DOT> com>
+
+pkgname=oof2
+pkgver='2.1.11'
+pkgrel=2
+pkgdesc="Finite element analysis of microstructures."
+arch=('i686' 'x86_64')
+url="http://www.ctcms.nist.gov/oof/oof2/index.html"
+license=('custom')
+depends=('python2' 'pygtk' 'libgnomecanvas' 'imagemagick' 'lapack')
+source=("http://www.ctcms.nist.gov/oof/oof2/source/${pkgname}-${pkgver}.tar.gz"
+ "LICENSE")
+md5sums=('a1061fc08dbed4a2c15d2c569849f858'
+ 'c1d808bd883c2e0a30b687e3fcec4847')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python2 setup.py build
+}
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ install -m 644 -D ${srcdir}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}