summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Klinkovský2023-10-07 19:15:27 +0200
committerJakub Klinkovský2023-10-07 19:15:27 +0200
commit1b0a60426e0abcc8983141508eae5d6b159c669a (patch)
tree929ab7ac8b40183e3cd028b93d0d5360c0be3807
downloadaur-1b0a60426e0abcc8983141508eae5d6b159c669a.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD36
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6f101149a49
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = oojs-ui-archlinux-git
+ pkgdesc = JavaScript UI library used by MediaWiki (with ArchLinux theme)
+ pkgver = v0.48.1.r5.g81bab18
+ pkgrel = 1
+ url = https://github.com/lahwaacz/oojs-ui
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = npm
+ makedepends = grunt-cli
+ makedepends = composer
+ source = git+https://github.com/lahwaacz/oojs-ui.git
+ sha256sums = SKIP
+
+pkgname = oojs-ui-archlinux-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f44a2635caff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Jakub Klinkovský <lahwaacz at archlinux dot org>
+
+_name=oojs-ui
+pkgname=$_name-archlinux-git
+pkgdesc="JavaScript UI library used by MediaWiki (with ArchLinux theme)"
+url="https://github.com/lahwaacz/oojs-ui"
+pkgver=v0.48.1.r5.g81bab18
+pkgrel=1
+license=(MIT)
+arch=(any)
+depends=()
+makedepends=(git npm grunt-cli composer)
+source=("git+https://github.com/lahwaacz/oojs-ui.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_name
+ git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $_name
+ npm install
+ grunt build
+
+ # archlinux theme has exactly the same icons as the wikimediaui theme
+ rm -rf dist/themes/archlinux
+ ln -s wikimediaui dist/themes/archlinux
+}
+
+package() {
+ cd $_name
+ install -dm755 "$pkgdir/usr/share"
+ mv dist "$pkgdir/usr/share/$_name-archlinux"
+ install -Dm644 LICENSE-MIT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}