summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoractionless2019-01-01 05:53:31 +0100
committeractionless2019-01-01 05:53:31 +0100
commit4d53442f962cc36c8509e0869bf64649acddd105 (patch)
treed5ab77e60b55aed8ff57fab9ab0c48576940100a
parent7e40916dd7b68e8aa27ce33637ad7bf36ccc41f7 (diff)
downloadaur-4d53442f962cc36c8509e0869bf64649acddd105.tar.gz
remove old submodule
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 333a439523e0..29d1760d1acd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = oomox-git
pkgdesc = Themix: GUI for generating different color variations of Arc, Materia, Oomox themes (GTK2, GTK3, Cinnamon, GNOME, MATE, Openbox, Xfwm), ArchDroid, Gnome-Colors, Numix icon themes, and terminal palettes. Have a hack for HiDPI in GTK2.
pkgver = 1.9.0.2.r85.g1b8e948c
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/themix-project/oomox
arch = x86_64
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index db4379d87016..d8d05072138e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=oomox-git
pkgver=1.9.0.2.r85.g1b8e948c
-pkgrel=1
+pkgrel=2
pkgdesc="Themix: GUI for generating different color variations
of Arc, Materia, Oomox themes
(GTK2, GTK3, Cinnamon, GNOME, MATE, Openbox, Xfwm),
@@ -87,6 +87,18 @@ pkgver() {
prepare(){
cd "${srcdir}/oomox"
+
+ # remove submodule if building package update without flushing the dir:
+ git submodule deinit --all || true
+ git config --get-regexp submodule | cut -d' ' -f1 | xargs -n1 git config --unset || true
+ old_paths=(
+ "$srcdir"/oomox/plugins/import_base16/base16-data
+ )
+ for path in "${old_paths[@]}" ; do
+ rm -fr "${path}"
+ done
+
+ # use already downloaded by makepkg git repos as submodules of the main:
git submodule init
git config submodule.gtk-theme.url $srcdir/oomox-gtk-theme
git config submodule.materia-theme.url $srcdir/materia-theme