summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoractionless2017-08-27 16:21:16 +0200
committeractionless2017-08-27 16:21:16 +0200
commitbcf271188579fa0058523488e8a98175105787e4 (patch)
treeb56c0c27e094a1777c7c6f845bc49c17d8a02856
parenta7fad4c60d76b6553d3aa660454f8c00995a47f5 (diff)
downloadaur-bcf271188579fa0058523488e8a98175105787e4.tar.gz
update to 1.3.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD38
2 files changed, 41 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 676e1306dac3..50982d408936 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = oomox-git
- pkgdesc = Graphical application for generating different color variations of Numix theme (GTK2, GTK3), gnome-colors and ArchDroid icon themes. Have a hack for HiDPI in gtk2.
- pkgver = 1.2.8
+ pkgdesc = Graphical application for generating different color variations of Numix and Flat-Plat themes (GTK2, GTK3), gnome-colors and ArchDroid icon themes. Have a hack for HiDPI in gtk2.
+ pkgver = 1.3.0
pkgrel = 1
url = https://github.com/actionless/oomox
arch = x86_64
@@ -8,6 +8,8 @@ pkgbase = oomox-git
license = GPLv3
depends = coreutils
depends = bash
+ depends = grep
+ depends = sed
depends = bc
depends = zip
depends = glib2
@@ -17,14 +19,17 @@ pkgbase = oomox-git
depends = gtk-engine-murrine
depends = gtk-engines
depends = polkit
+ depends = parallel
+ depends = optipng
+ depends = inkscape
+ depends = imagemagick
optdepends = xorg-xrdb: for the `xresources` theme
- optdepends = imagemagick: for icon theme generation
- optdepends = inkscape: for icon theme generation
- optdepends = gnome-colors-common-icon-theme: for using the generated icon theme
optdepends = breeze-icons: more fallback icons
optdepends = gksu: for applying Spotify theme from GUI without polkit
source = git+https://github.com/actionless/oomox.git#branch=master
source = git+https://github.com/actionless/oomox-gtk-theme.git#branch=master
+ source = git+https://github.com/nana-4/Flat-Plat.git#branch=master
+ md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 9bcb7b9a174c..f4aac9afb1fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,11 @@
# Upstream URL: https://github.com/actionless/oomox
pkgname=oomox-git
-pkgver=1.2.8
+pkgver=1.3.0
pkgrel=1
pkgdesc="Graphical application for generating different color variations
-of Numix theme (GTK2, GTK3), gnome-colors and ArchDroid icon themes.
+of Numix and Flat-Plat themes (GTK2, GTK3),
+gnome-colors and ArchDroid icon themes.
Have a hack for HiDPI in gtk2."
arch=('x86_64' 'i686')
url="https://github.com/actionless/oomox"
@@ -13,14 +14,18 @@ license=('GPLv3')
source=(
"git+https://github.com/actionless/oomox.git#branch=master"
"git+https://github.com/actionless/oomox-gtk-theme.git#branch=master"
+ "git+https://github.com/nana-4/Flat-Plat.git#branch=master"
)
md5sums=(
"SKIP"
"SKIP"
+ "SKIP"
)
depends=(
'coreutils'
'bash'
+ 'grep'
+ 'sed'
'bc'
'zip'
'glib2'
@@ -30,15 +35,15 @@ depends=(
'gtk-engine-murrine'
'gtk-engines'
'polkit'
+ 'parallel'
+ 'optipng'
+ 'inkscape'
+ 'imagemagick'
)
optdepends=(
'xorg-xrdb: for the `xresources` theme'
- 'imagemagick: for icon theme generation'
- 'inkscape: for icon theme generation'
- 'gnome-colors-common-icon-theme: for using the generated icon theme'
'breeze-icons: more fallback icons'
'gksu: for applying Spotify theme from GUI without polkit'
- #'gnome-colors-icon-theme: for using the generated icon theme' it's broken ATM
)
pkgver() {
@@ -49,7 +54,8 @@ pkgver() {
prepare(){
cd "${srcdir}/oomox"
git submodule init
- git config submodule.mysubmodule.url $srcdir/oomox-gtk-theme
+ git config submodule.gtk_theme.url $srcdir/oomox-gtk-theme
+ git config submodule.flatplat_theme.url $srcdir/Flat-Plat
git submodule update
}
@@ -57,6 +63,7 @@ package() {
mkdir -p ${pkgdir}/opt/oomox
cd ./oomox
make -f po.mk install
+
cp -prf \
./CREDITS \
./LICENSE \
@@ -73,6 +80,7 @@ package() {
./po \
./scripts \
${pkgdir}/opt/oomox
+
mkdir ${pkgdir}/opt/oomox/gtk-theme
cd ./gtk-theme
cp -prf \
@@ -85,6 +93,22 @@ package() {
./scripts \
./src \
${pkgdir}/opt/oomox/gtk-theme
+ cd ..
+
+ mkdir ${pkgdir}/opt/oomox/flat-plat-theme
+ cd ./flat-plat-theme
+ cp -prf \
+ ./COPYING \
+ ./HACKING.md \
+ ./README.md \
+ ./change_color.sh \
+ ./install.sh \
+ ./parse-sass.sh \
+ ./scripts \
+ ./src \
+ ${pkgdir}/opt/oomox/flat-plat-theme
+ cd ..
+
python -O -m compileall ${pkgdir}/opt/oomox/oomox_gui
mkdir -p ${pkgdir}/usr/bin/
mkdir -p ${pkgdir}/usr/share/applications/