summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMantas Mikulėnas2019-04-29 10:16:11 +0300
committerMantas Mikulėnas2019-04-29 10:16:11 +0300
commit6658c2c69ba30ec5ad898028f3da4633ce5496e0 (patch)
tree2a667eb77883732ea9dcb92ca6452b458b70aca5
parent9572a9fa3053b0d9c23ba236e7098ee1ca90ea6e (diff)
downloadaur-6658c2c69ba30ec5ad898028f3da4633ce5496e0.tar.gz
work around build system ignoring DESTDIR
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b77488928071..0532c87496a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,7 +28,12 @@ build() {
package() {
cd oor
- make PREFIX="/usr/bin/" DESTDIR="$pkgdir" install
+ install -dm755 "$pkgdir"/usr/lib/systemd/system
+ make \
+ DESTDIR="$pkgdir" \
+ PREFIX="/usr/bin/" \
+ SERVICEPREF="$pkgdir/usr/lib/systemd/system/" \
+ install
install -Dm600 oor/oor.conf.example "$pkgdir"/usr/share/doc/"$pkgname"/oor.conf
install -Dm644 "$srcdir"/oor.service "$pkgdir"/usr/lib/systemd/system/oor.service
}